Problema booting Windows 8 e Ubuntu 12.10

Pagina 1 di 5 1 2 3 4 5 ultimo
Visualizzazione dei risultati da 1 a 10 su 50
  1. #1
    bit L'avatar di Pigreco91
    Registrato
    Feb 2014
    Messaggi
    48
    configurazione

    Predefinito Problema booting Windows 8 e Ubuntu 12.10

    Buongiorno gente,

    sto provando a mettere in dual boot il mio pc che presenta un sistema UEFI ( non sapete quanti problemi mi abbia già procurato questo aspetto della vicenda) e dopo diverse vicissitudini sono finalmente riuscito ad arrivare ad una schermata del Grub2 in cui si riuscisse ad accedere Ubuntu, EVVIVA!

    Peccato però che adesso non mi sia più possibile accedere a windows 8.

    Ho provato a seguire le indicazioni del mitico frakka ( trovate in quest'altra discussione --> http://www.nexthardware.com/forum/gn...rtatile-6.html in particolare alla risposta #55), ma comunque quando provo ad accedere a windows 8 ( anche tramite la voce "esci da uefi ecc... aggiunta nel grub come da indicazioni) sbatto inesorabilmente la testa contro l'errore del grub rescue:

    error: file '(hd0,msdos4)/boot/grub/i386-pc/normal.mod' not found
    error: grub rescue.

    Questo è ciò che mostra gParted:

    Problema booting Windows 8 e Ubuntu 12.10-schermata-gparted.jpg


    Maghi, please aiutatemi.
    Ultima modifica di Pigreco91 : 22-02-2014 a 14:46

  2. #2
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    38
    Messaggi
    22,071
    configurazione

    Predefinito

    Piuttosto insolito, ma tu la partizione EFI ce l'hai in sda3, hai tenuto conto di questo?
    Spiegami per favore come è stato installato/partizionato il disco che non riesco a capirlo...

    Hai installato le versioni a 32bit di ubuntu/Windows8?? Il disco è partizionato in MBR, vero?
    Posta anche il contenuto del grub.conf
    Pigreco91 likes this.


    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Nessuno capì che Ognuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

  3. #3
    bit L'avatar di Pigreco91
    Registrato
    Feb 2014
    Messaggi
    48
    configurazione

    Predefinito

    Ciao frakka, grazie per la risposta così rapida.

    Il sunto della storia è questo:
    - Pc con tecnologia UEFI con installato windows 8 64 bit;
    - Installazione di Ubuntu 12.10 da CD Live non riuscita perchè non ho seguito la guida corretta per sistema UEFI
    - Nuovo tentativo di installazione di Ubuntu 12.10 creando prima una partizione di avvio EFI in sda3 e di Ubuntu 12.10 in sda4. Installazione riuscita.
    - All'avvio del Grub la voce Ubuntu funzionava avviando correttamente il SO. La voce windows 8 invece riportava l'errore che anche tu avevi incontrato:

    errore: impossibile trovare il comando "drivemap" .
    errore: invalid EFI path.

    - A questo punto ho provato a editare il file /etc/grub.d/40_custom come da tue indicazioni e ad ordinare il Boot Sequence.
    - La voce aggiuntasi nel grub riporta quell'errore nel grub rescue che ho riportato sopra

    Documentandomi un pò ho scoperto che data la versione 64 bit il mio disco deve essere partizionato GPT e non MRB, potrebbe essere questo il problema ma non so trarne le conseguenze.

    Dammi qualche minuto per il grub.conf che al momento sono su un altro pc

  4. #4
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    38
    Messaggi
    22,071
    configurazione

    Predefinito

    Il problema è probabilmente che, anche se l'hardware ha pieno supporto EFI, Windows 8 è stato installato in modalità MBR.

    Quando hai installato Ubuntu lo hai fatto in modalità in modalità EFI quindi il bootloader di Ubuntu è configurato per cercare delle applicazioni "EFI" da avviare e ti restituisce quel messaggio di errore perchè non c'è un bootloader EFI per Windows in quando Windows 8 è installato in modalità MBR.

    Già anche con altri utenti abbiamo tentato di risolvere il problema ma non ne siamo venuti a capo perchè non c'è una vera soluzione: Conviene mantenere le modalità di installazione omogenee quindi o tutto EFI o tutto MBR.
    L'alternativa è che ti imposti come primario nella mobo il boot di Ubuntu UEFI e come secondario il boot in modalità MBR dello stesso disco. Poi usi il trucco della funzione "exit".
    Pigreco91 likes this.


    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Nessuno capì che Ognuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

  5. #5
    bit L'avatar di Pigreco91
    Registrato
    Feb 2014
    Messaggi
    48
    configurazione

    Predefinito

    Hmhm il fatto è che il trucco della funzione exit non mi ha funzionato, forse ho sbagliato qualcosa nell'ordine del Boot Sequence... riprovo e ti aggiorno.

    Altrimenti come posso fare a installare anche Ubuntu in MBR? Quando ho provato la prima volta ad installarlo seguendo una guida standard non mi faceva mai proseguire. c'è un modo per disabilitare il sistema UEFI che tu sappia?

    Grazie mille

    [Edit: le tre voci di scelta che ho del boot sono :
    1) Ubuntu (uefi)
    2) P1: ST1000DM003-1CH162
    3) P0: TSSTcorp CDDVDW SH-224DB
    però anche invertendo il 2 con il 3 non si risolve il problema]
    Ultima modifica di Pigreco91 : 23-02-2014 a 03:08

  6. #6
    bit L'avatar di Pigreco91
    Registrato
    Feb 2014
    Messaggi
    48
    configurazione

    Predefinito

    Il file grub.conf non l'ho trovato, intendevi il grub cfg? se si eccolo, se no cancello subito questa risposta

    codice:
    #
    # DO NOT EDIT THIS FILE
    #
    # It is automatically generated by grub-mkconfig using templates
    # from /etc/grub.d and settings from /etc/default/grub
    #
    
    ### BEGIN /etc/grub.d/00_header ###
    if [ -s $prefix/grubenv ]; then
      set have_grubenv=true
      load_env
    fi
    set default="0"
    
    if [ x"${feature_menuentry_id}" = xy ]; then
      menuentry_id_option="--id"
    else
      menuentry_id_option=""
    fi
    
    export menuentry_id_option
    
    if [ "${prev_saved_entry}" ]; then
      set saved_entry="${prev_saved_entry}"
      save_env saved_entry
      set prev_saved_entry=
      save_env prev_saved_entry
      set boot_once=true
    fi
    
    function savedefault {
      if [ -z "${boot_once}" ]; then
        saved_entry="${chosen}"
        save_env saved_entry
      fi
    }
    
    function recordfail {
      set recordfail=1
      if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
    }
    
    function load_video {
      if [ x$feature_all_video_module = xy ]; then
        insmod all_video
      else
        insmod efi_gop
        insmod efi_uga
        insmod ieee1275_fb
        insmod vbe
        insmod vga
        insmod video_bochs
        insmod video_cirrus
      fi
    }
    
    if [ x$feature_default_font_path = xy ] ; then
       font=unicode
    else
    insmod part_msdos
    insmod ext2
    set root='hd0,msdos4'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos4 --hint-efi=hd0,msdos4 --hint-baremetal=ahci0,msdos4  0237e26f-0603-4511-b329-ce9d2de09f5d
    else
      search --no-floppy --fs-uuid --set=root 0237e26f-0603-4511-b329-ce9d2de09f5d
    fi
        font="/usr/share/grub/unicode.pf2"
    fi
    
    if loadfont $font ; then
      set gfxmode=auto
      load_video
      insmod gfxterm
      set locale_dir=$prefix/locale
      set lang=it_IT
      insmod gettext
    fi
    terminal_output gfxterm
    if [ "${recordfail}" = 1 ]; then
      set timeout=-1
    else
      set timeout=10
    fi
    ### END /etc/grub.d/00_header ###
    
    ### BEGIN /etc/grub.d/05_debian_theme ###
    set menu_color_normal=white/black
    set menu_color_highlight=black/light-gray
    if background_color 44,0,30; then
      clear
    fi
    ### END /etc/grub.d/05_debian_theme ###
    
    ### BEGIN /etc/grub.d/10_linux ###
    function gfxmode {
    	set gfxpayload="${1}"
    	if [ "${1}" = "keep" ]; then
    		set vt_handoff=vt.handoff=7
    	else
    		set vt_handoff=
    	fi
    }
    if [ "${recordfail}" != 1 ]; then
      if [ -e ${prefix}/gfxblacklist.txt ]; then
        if hwmatch ${prefix}/gfxblacklist.txt 3; then
          if [ ${match} = 0 ]; then
            set linux_gfx_mode=keep
          else
            set linux_gfx_mode=text
          fi
        else
          set linux_gfx_mode=text
        fi
      else
        set linux_gfx_mode=keep
      fi
    else
      set linux_gfx_mode=text
    fi
    export linux_gfx_mode
    if [ "${linux_gfx_mode}" != "text" ]; then load_video; fi
    menuentry 'Ubuntu' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-0237e26f-0603-4511-b329-ce9d2de09f5d' {
    recordfail
    	gfxmode $linux_gfx_mode
    	insmod gzio
    	insmod part_msdos
    	insmod ext2
    	set root='hd0,msdos4'
    	if [ x$feature_platform_search_hint = xy ]; then
    	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos4 --hint-efi=hd0,msdos4 --hint-baremetal=ahci0,msdos4  0237e26f-0603-4511-b329-ce9d2de09f5d
    	else
    	  search --no-floppy --fs-uuid --set=root 0237e26f-0603-4511-b329-ce9d2de09f5d
    	fi
    	linux	/boot/vmlinuz-3.5.0-17-generic root=UUID=0237e26f-0603-4511-b329-ce9d2de09f5d ro   quiet splash $vt_handoff
    	initrd	/boot/initrd.img-3.5.0-17-generic
    }
    submenu 'Opzioni avanzate per Ubuntu' $menuentry_id_option 'gnulinux-advanced-0237e26f-0603-4511-b329-ce9d2de09f5d' {
    	menuentry 'Ubuntu, con Linux 3.5.0-17-generic' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.5.0-17-generic-advanced-0237e26f-0603-4511-b329-ce9d2de09f5d' {
    	recordfail
    		gfxmode $linux_gfx_mode
    		insmod gzio
    		insmod part_msdos
    		insmod ext2
    		set root='hd0,msdos4'
    		if [ x$feature_platform_search_hint = xy ]; then
    		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos4 --hint-efi=hd0,msdos4 --hint-baremetal=ahci0,msdos4  0237e26f-0603-4511-b329-ce9d2de09f5d
    		else
    		  search --no-floppy --fs-uuid --set=root 0237e26f-0603-4511-b329-ce9d2de09f5d
    		fi
    		echo	'Caricamento Linux 3.5.0-17-generic...'
    		linux	/boot/vmlinuz-3.5.0-17-generic root=UUID=0237e26f-0603-4511-b329-ce9d2de09f5d ro   quiet splash $vt_handoff
    		echo	'Caricamento ramdisk iniziale...'
    		initrd	/boot/initrd.img-3.5.0-17-generic
    	}
    	menuentry 'Ubuntu, con Linux 3.5.0-17-generic (modalità ripristino)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.5.0-17-generic-recovery-0237e26f-0603-4511-b329-ce9d2de09f5d' {
    	recordfail
    		insmod gzio
    		insmod part_msdos
    		insmod ext2
    		set root='hd0,msdos4'
    		if [ x$feature_platform_search_hint = xy ]; then
    		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos4 --hint-efi=hd0,msdos4 --hint-baremetal=ahci0,msdos4  0237e26f-0603-4511-b329-ce9d2de09f5d
    		else
    		  search --no-floppy --fs-uuid --set=root 0237e26f-0603-4511-b329-ce9d2de09f5d
    		fi
    		echo	'Caricamento Linux 3.5.0-17-generic...'
    		linux	/boot/vmlinuz-3.5.0-17-generic root=UUID=0237e26f-0603-4511-b329-ce9d2de09f5d ro recovery nomodeset 
    		echo	'Caricamento ramdisk iniziale...'
    		initrd	/boot/initrd.img-3.5.0-17-generic
    	}
    }
    
    ### END /etc/grub.d/10_linux ###
    
    ### BEGIN /etc/grub.d/20_linux_xen ###
    
    ### END /etc/grub.d/20_linux_xen ###
    
    ### BEGIN /etc/grub.d/20_memtest86+ ###
    ### END /etc/grub.d/20_memtest86+ ###
    
    ### BEGIN /etc/grub.d/30_os-prober ###
    menuentry 'Windows 8 (loader) (su /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-306802126801D80C' {
    	insmod part_msdos
    	insmod ntfs
    	set root='hd0,msdos1'
    	if [ x$feature_platform_search_hint = xy ]; then
    	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  306802126801D80C
    	else
    	  search --no-floppy --fs-uuid --set=root 306802126801D80C
    	fi
    	drivemap -s (hd0) ${root}
    	chainloader +1
    }
    ### END /etc/grub.d/30_os-prober ###
    
    ### BEGIN /etc/grub.d/30_uefi-firmware ###
    menuentry 'System setup' $menuentry_id_option 'uefi-firmware' {
    	fwsetup
    }
    ### END /etc/grub.d/30_uefi-firmware ###
    
    ### BEGIN /etc/grub.d/40_custom ###
    # This file provides an easy way to add custom menu entries.  Simply type the
    # menu entries you want to add after this comment.  Be careful not to change
    # the 'exec tail' line above.
    
    menuentry 'Esci da GRUB UEFI ed avvia Windows8' {
    exit
    }
    ### END /etc/grub.d/40_custom ###
    
    ### BEGIN /etc/grub.d/41_custom ###
    if [ -f  ${config_directory}/custom.cfg ]; then
      source ${config_directory}/custom.cfg
    elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
      source $prefix/custom.cfg;
    fi
    ### END /etc/grub.d/41_custom ###
    Ultima modifica di frakka : 23-02-2014 a 10:57

  7. #7
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    38
    Messaggi
    22,071
    configurazione

    Predefinito

    Originariamente inviato da Pigreco91
    Hmhm il fatto è che il trucco della funzione exit non mi ha funzionato, forse ho sbagliato qualcosa nell'ordine del Boot Sequence... riprovo e ti aggiorno.

    Altrimenti come posso fare a installare anche Ubuntu in MBR? Quando ho provato la prima volta ad installarlo seguendo una guida standard non mi faceva mai proseguire. c'è un modo per disabilitare il sistema UEFI che tu sappia?

    Grazie mille

    [Edit: le tre voci di scelta che ho del boot sono :
    1) Ubuntu (uefi)
    2) P1: ST1000DM003-1CH162
    3) P0: TSSTcorp CDDVDW SH-224DB
    però anche invertendo il 2 con il 3 non si risolve il problema]
    Per fare l'installazione di ubuntu in modalità MBR devi avviare il sistema dalla voce "3", in modo che l'installer di ubuntu non rilevi un avvio di tipo uefi,
    Non dovrebbe servire altro ma ti devi ricordare di impostare l'installazione nel bootloader in "/dev/sda" e non in "/dev/sda+numero".

    Puoi disabilitare completamente UEFI nel bios, è sufficiente che tra le opzioni di boot lasci solo "legacy" (la dicitura può cambiare in base alla mobo).

    P.S:
    Di preciso non ricordo ma può darsi che ci siano problemi ad installare GRUB2 per un problema di spazio all'inizio del disco... Se ti dà messaggi di errore riportameli, per favore.
    Pigreco91 likes this.


    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Nessuno capì che Ognuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

  8. #8
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    38
    Messaggi
    22,071
    configurazione

    Predefinito

    Originariamente inviato da Pigreco91
    Hmhm il fatto è che il trucco della funzione exit non mi ha funzionato, forse ho sbagliato qualcosa nell'ordine del Boot Sequence... riprovo e ti aggiorno.
    [...]
    [Edit: le tre voci di scelta che ho del boot sono :
    1) Ubuntu (uefi)
    2) P1: ST1000DM003-1CH162
    3) P0: TSSTcorp CDDVDW SH-224DB
    però anche invertendo il 2 con il 3 non si risolve il problema]
    No, così è corretto, dovrebbe funzionare.
    Nessun messaggio di errore???
    Pigreco91 likes this.


    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Nessuno capì che Ognuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

  9. #9
    bit L'avatar di Pigreco91
    Registrato
    Feb 2014
    Messaggi
    48
    configurazione

    Predefinito

    Originariamente inviato da frakka
    Non dovrebbe servire altro ma ti devi ricordare di impostare l'installazione nel bootloader in "/dev/sda" e non in "/dev/sda+numero".
    Scusa l'ignoranza, ma esattamente come faccio a impostare l'installazione nel bootloader in "/dev/sda" e a che punto dell'installazione?

  10. #10
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    38
    Messaggi
    22,071
    configurazione

    Predefinito

    E' un pò che non installo ubuntu ma se non ricordo male è l'ultima cosa che ti chiede alla fine dell'installazione. Puoi scegliere se installare il bootloader nel master boot record (mbr, equivale alla dicitura sda oppure hd0) o nella prima partizione del disco (sda1 o hd0,0).
    Dovrebbe essere un cosa del genere... aspetta un attimo che vedo se ho la iso da qualche parte...
    Pigreco91 likes this.


    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Nessuno capì che Ognuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

Pagina 1 di 5 1 2 3 4 5 ultimo

Informazioni Thread

Users Browsing this Thread

Ci sono attualmente 1 utenti che stanno visualizzando questa discussione. (0 utenti e 1 ospiti)

Regole d'invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
nexthardware.com - © 2002-2018

Search Engine Optimization by vBSEO 3.6.1