Windows XP riavvio continuo dopo logon/login

Visualizzazione dei risultati da 1 a 9 su 9
  1. #1
    Aborigeno WEB L'avatar di TheMic
    Registrato
    May 2003
    Località
    Avezzano (AQ)
    Età
    38
    Messaggi
    4,989

    Predefinito Windows XP riavvio continuo dopo logon/login

    Salve gente...
    questa non è una richiesta di aiuto... ma una condivisione della soluzione al problema.

    Ultimamente già su due pc di miei amici è capitata questa noiosa perdita di tempo... si avvia XP, scegli il tuo nome utente, inizia il logon.... eeee ... windows fa vedere per un paio di secondo lo sfondo per poi tornare alla schermata per la scelta dell'utente. E tutto questo va avanti all'infinito... anche in modalità provvisoria!

    La prima volta che ho visto questo problema, mi sono ritrovato in mano un pc HP con AMD sopra... e pensai ERRONEAMENTE, quindi, al già stranoto problema del ServicePack3 (come qui descritto: http://www.nexthardware.com/forum/sh...58#post649758). Ma non è così... in questo caso questo scassamento sembra derivare da un virus di cui non si conosce il nome (io non sono riuscito a trovarlo) che non fa altri danni e non è riconosciuto dagli antivirus!

    Ora... per chi volesse evitare la formattazione del disco... ecco la soluzione: (attenzione... solo per utenti esperti con il registro di sistema)
    Bisogna entrare nella console di ripristino... naturalmente attraverso il CD di installazione di Windows XP.
    Nella Console dovete digitare una serie di comandi che vi permetteranno di rimettere su una versione funzionante del blocco HIVE SOFTWARE dentro Config. ecco i comandi:
    codice:
    C:\windows>cd %windir%\system32\config
    C:\windows\system32\config>ren software software.old
    C:\windows\system32\config>copy C:\%windir%\repair\software
    Dopo queste operazioni dovrebbe comparire un messaggio: "1 file(s) copied"
    Ora digitate questo comando:
    codice:
    C:\windows\system32\config>exit
    ATTENZIONE: Dopo questo comando rimuovete il CD di installazione di Windows, e entrate nella modalità provvisoria di windows (bisogna premere F8). Se non si entra in modalità provvisoria windows vi chiederà di riattivare la copia e non sarà possibile utilizzarlo.

    Entrati quindi in modalità provvisoria, dovrete accedere a windows con l'account ADMINISTRATOR.
    Ora una volta dentro windows bisognerà modificare il registro di sistema per cambiare il percorso del file userinit.exe in questo modo:
    codice:
    aprite regedit.exe
    selezionate HKEY_LOCAL_MACHINE (mi raccomando... SELEZIONATELA altrimenti farete un macello... ^_^)
    aprite il menù file
    e cliccate su Carica hive...
    Ora selezionate il vecchio file backuppato in precedenza attraverso la console di ripristino... se prima avete fatto tutto bene dovreste avere il file in C:\windows\system32\config\ e tale file si chiamerà software.old.
    dopo averlo scelto vi verrà chiesto di dargli un nome per inserirlo dentro al registro... potete mettere qualsiasi nome.. io ad esempio ho usato il nome "test"!

    ORA:
    codice:
    entrate nella cartella:
    HKEY_LOCAL_MACHINE\\microsoft\windows nt\currentversion\winlogon.
    Ora nella finestra di destra guardate il valore dentro userinit dovrebbe essere %system32%\userinit.exe che non è valido.
    Cambiate questo valore con: C:\windows\system32\userinit.exe (vi basta fare doppio click su userinit e vi si aprirà una finestra per la modifica)
    Bene, abbiamo quasi finito... fatte tutte queste operazioni, chiudete REGEDIT e riavviate windows... reinserite il CD di Windows XP e rientrate nella Console di Ripristino.

    Una volta rientrati nella Console bisogna ripristinare il vecchio file che avevamo salvato... in questo modo:
    C:\windows>cd system32\config
    C:\windows\system32\config>del software
    C:\windows\system32\config>ren software.old software
    C:\windows\system32\config>exit


    Togliete il disco di XP e finalmente potrete tornare ad utilizzare il vostro caro vecchio WinZozz!


    ZAO!

  2. #2
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    38
    Messaggi
    22,114
    configurazione

    Predefinito

    Il problema è capitato anche a me un pò di tempo fà in laboratorio.

    Nel mio caso fu sufficiente copiare il file userinit.exe da un altro pc e sostituirlo a quello danneggiato sul pc in assistenza.
    In teoria è necessario copiarlo da un pc con installata la stessa versione di windows. Nel mio caso, non avendo una altro pc con XP SP3 a portata di mano, gli ho copiato il file di un XP SP2 ed ha funzionato lo stesso.

    Dopo il riavvio del pc con installato il nuovo file ha funzionato tutto.


    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Ognuno capì che Nessuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

  3. #3
    Nihil est magnum somnianti L'avatar di brugola.x
    Registrato
    Feb 2007
    Località
    1/2 lombardo
    Età
    46
    Messaggi
    18,588
    configurazione

    Predefinito

    speriamo non serva.. ma sempre buona a sapersi..

  4. #4
    Aborigeno WEB L'avatar di TheMic
    Registrato
    May 2003
    Località
    Avezzano (AQ)
    Età
    38
    Messaggi
    4,989

    Predefinito

    Originariamente inviato da frakka
    Il problema è capitato anche a me un pò di tempo fà in laboratorio.

    Nel mio caso fu sufficiente copiare il file userinit.exe da un altro pc e sostituirlo a quello danneggiato sul pc in assistenza.
    In teoria è necessario copiarlo da un pc con installata la stessa versione di windows. Nel mio caso, non avendo una altro pc con XP SP3 a portata di mano, gli ho copiato il file di un XP SP2 ed ha funzionato lo stesso.

    Dopo il riavvio del pc con installato il nuovo file ha funzionato tutto.
    e dirmelo prima no è?!?!?

    quando cercai di risolvere la prima volta rimasi 4 giorni a bestemmiarci su...

    comunque buona a sapersi anche la tua soluzione anche perché nella mia era proprio errato il percorso!

  5. #5
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    38
    Messaggi
    22,114
    configurazione

    Predefinito

    Probabilmente sono soluzioni diverse per un problema simile, dovuto a cause diverse.
    Abbiamo appurato che la disconnessione continua è dovuto a problemi con il file userinit.exe

    Poi le cause possono essere diverse. Leggevo che spesso il file userinit viene spesso danneggiato da software antivirus o antispyware, perchè oggetto di attacco da parte di varie schifezzuole che questi software cercano di disinfettare, peggiorando la situazione.


    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Ognuno capì che Nessuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

  6. #6
    Aborigeno WEB L'avatar di TheMic
    Registrato
    May 2003
    Località
    Avezzano (AQ)
    Età
    38
    Messaggi
    4,989

    Predefinito

    Originariamente inviato da frakka
    Probabilmente sono soluzioni diverse per un problema simile, dovuto a cause diverse.
    Abbiamo appurato che la disconnessione continua è dovuto a problemi con il file userinit.exe

    Poi le cause possono essere diverse. Leggevo che spesso il file userinit viene spesso danneggiato da software antivirus o antispyware, perchè oggetto di attacco da parte di varie schifezzuole che questi software cercano di disinfettare, peggiorando la situazione.
    Si infatti... hai pienamente ragione.. ti quoto in pieno!
    ma il bello è che questa soluzione l'ho trovata su un sito sperduto in lingua inglese... su siti italiani nemmeno un accenno al problema.

  7. #7
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    38
    Messaggi
    22,114
    configurazione

    Predefinito

    Io la mia la trovai sul sito di MS.


    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Ognuno capì che Nessuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

  8. #8
    Aborigeno WEB L'avatar di TheMic
    Registrato
    May 2003
    Località
    Avezzano (AQ)
    Età
    38
    Messaggi
    4,989

    Predefinito

    riporto su la discussione per linkare un sito italiano che finalmente ne parla di questo problema: PCOPEN


  9. #9
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    38
    Messaggi
    22,114
    configurazione

    Predefinito

    Ottimo, grazie!!


    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Ognuno capì che Nessuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

Informazioni Thread

Users Browsing this Thread

Ci sono attualmente 1 utenti che stanno visualizzando questa discussione. (0 utenti e 1 ospiti)

Discussioni simili

  1. Riavvio continuo con schermata blu
    By Io2 in forum -= Hardware generico =-
    Risposte: 3
    Ultimo messaggio: 29-05-2011, 11:29
  2. Riavvio continuo - problema hd?
    By Antani in forum -= Periferiche di memorizzazione =-
    Risposte: 4
    Ultimo messaggio: 21-09-2009, 08:28
  3. GUI login screen kde - kdm theme login
    By giostark in forum Appunti/How-To
    Risposte: 1
    Ultimo messaggio: 16-09-2009, 09:47
  4. problema riavvio windows xp
    By mbenecchi in forum -= Sistemi Operativi Windows e software generale =-
    Risposte: 1
    Ultimo messaggio: 31-05-2007, 08:40
  5. WINDOWS SI SPEGNE O CRASHA DOPO 50 GIORNI D CONTINUO USO?
    By Fabio Norway Storm in forum -= Sistemi Operativi Windows e software generale =-
    Risposte: 4
    Ultimo messaggio: 04-02-2001, 23:35

Tags

Regole d'invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
nexthardware.com - © 2002-2018

Search Engine Optimization by vBSEO 3.6.1