Like Tree324Likes

Guida a Logitech Media Server, Squeezelite e derivati.

Pagina 33 di 187
prima
... 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 83 133 ... ultimo
Visualizzazione dei risultati da 321 a 330 su 1861
  1. #321
    tebibyte
    Registrato
    Aug 2011
    Età
    47
    Messaggi
    2,917
    configurazione

    Predefinito

    Originariamente inviato da blueray
    No, deve essere in quel modo se no squeezelite non parte.
    Non credo Federico.

    questo con il tuo comando
    codice:
    19:08:38.578380] stream_init:290 init stream
    [19:08:38.578459] stream_init:291 streambuf size: 2097152
    [19:08:38.579073] output_init_alsa:817 init output
    [19:08:38.579098] output_init_alsa:846 requested alsa_buffer: 0 alsa_period: 20 format: p mmap: 1
    [19:08:38.579114] output_init_common:346 outputbuf size: 3528000
    [19:08:38.579148] output_init_common:370 idle timeout: 0
    [19:08:38.581405] output_init_common:410 supported rates: 384000 352800 192000 176400 96000 88200 48000 44100
    [19:08:38.582698] output_init_alsa:862 memory locked
    [19:08:38.582822] output_thread:638 open output device: front:CARD=J20,DEV=0
    [19:08:38.582825] output_init_alsa:885 set output sched fifo rt: 45
    [19:08:38.583158] alsa_open:355 opening device at: 44100
    [19:08:38.583404] alsa_open:406 opened device front:CARD=J20,DEV=0 using format: S32_LE sample rate: 44100 mmap: 1
    [19:08:38.583424] alsa_open:485 buffer: 0 period: 20 -> buffer size: 160 period size: 8
    [19:08:38.583936] decode_init:129 init decode, include codecs:  exclude codecs:
    [19:08:38.583980] register_dsd:624 using dsd to decode dsf,dff
    [19:08:38.594173] load_ff:621 loaded libavcodec.so.56 (56.1.0)
    [19:08:38.594200] load_ff:638 loaded libavformat.so.56 (56.1.0)
    [19:08:38.594209] load_ff:652 loaded libavutil.so.54 (54.3.0)
    [19:08:38.595524] register_ff:731 using ffmpeg to decode alc
    [19:08:38.595544] register_ff:715 using ffmpeg to decode wma,wmap,wmal
    [19:08:38.595665] load_faad:610 loaded libfaad.so.2
    [19:08:38.595676] register_faad:640 using faad to decode aac
    [19:08:38.595765] load_vorbis:300 loaded libvorbisfile.so.3
    [19:08:38.595776] register_vorbis:329 using vorbis to decode ogg
    [19:08:38.595934] load_flac:258 loaded libFLAC.so.8
    [19:08:38.595945] register_flac:286 using flac to decode flc
    [19:08:38.595951] register_pcm:392 using pcm to decode aif,pcm
    [19:08:38.596037] load_mad:383 loaded libmad.so.0
    [19:08:38.596050] register_mad:412 using mad to decode mp3
    [19:08:38.596114] discover_server:756 sending discovery
    [19:08:38.596933] discover_server:767 got response from: 192.168.178.21:3483
    [19:08:38.596954] slimproto:849 connecting to 192.168.178.21:3483
    [19:08:38.597661] slimproto:882 connected
    [19:08:38.597673] sendHELO:124 mac: 50:e5:49:cc:b4:29
    [19:08:38.597679] sendHELO:126 cap: Model=squeezelite,AccuratePlayPoints=1,HasDigitalOut=1,HasPolarityInversion=1,Firmware=v1.8,ModelName=SqueezeLite,MaxSampleRate=384000,dsf,dff,alc,wma,wmap,wmal,aac,ogg,flc,aif,pcm,mp3
    [19:08:38.652315] process:494 strm
    [19:08:38.652327] process_strm:256 strm command q
    [19:08:38.652334] decode_flush:190 decode flush
    [19:08:38.652339] output_flush:423 flush output buffer
    [19:08:38.652346] sendSTAT:171 STAT: STMf
    [19:08:38.652400] process:494 strm
    [19:08:38.652409] process_strm:256 strm command q
    [19:08:38.652414] decode_flush:190 decode flush
    [19:08:38.652419] output_flush:423 flush output buffer
    [19:08:38.652425] sendSTAT:171 STAT: STMf
    [19:08:38.652456] process:494 setd
    [19:08:38.652474] process:494 setd
    [19:08:38.652507] process:494 aude
    [19:08:38.652522] process_aude:395 enable spdif: 1 dac: 1
    [19:08:38.652571] process:494 audg
    [19:08:38.652580] process_audg:413 audg gainL: 65536 gainR: 65536 adjust: 0
    [19:08:38.652588] set_volume:246 setting internal gain left: 65536 right: 65536
    [19:08:40.098551] process:494 strm
    [19:08:40.098564] process_strm:256 strm command t
    [19:08:40.098570] sendSTAT:171 STAT: STMt
    [19:08:45.098448] process:494 strm
    [19:08:45.098463] process_strm:256 strm command t
    [19:08:45.098470] sendSTAT:171 STAT: STMt
    [19:08:50.098834] process:494 strm
    [19:08:50.098849] process_strm:256 strm command t
    [19:08:50.098857] sendSTAT:171 STAT: STMt
    [19:08:52.180664] slimproto_stop:920 slimproto stop
    [19:08:52.280757] decode_close:175 close decode
    [19:08:52.303140] stream_close:322 close stream
    [19:08:52.386616] output_close_alsa:890 close output
    Questo con quello giusto:
    codice:
    [[19:12:15.267174] stream_init:290 init stream
    [19:12:15.267259] stream_init:291 streambuf size: 2097152
    [19:12:15.267845] output_init_alsa:817 init output
    [19:12:15.267869] output_init_alsa:846 requested alsa_buffer: 20 alsa_period: 3 format: 24 mmap: 1
    [19:12:15.267881] output_init_common:346 outputbuf size: 3528000
    [19:12:15.267902] output_init_common:370 idle timeout: 0
    [19:12:15.270124] output_init_common:410 supported rates: 384000 352800 192000 176400 96000 88200 48000 44100
    [19:12:15.271424] output_init_alsa:862 memory locked
    [19:12:15.271533] output_thread:638 open output device: front:CARD=J20,DEV=0
    [19:12:15.271535] output_init_alsa:885 set output sched fifo rt: 45
    [19:12:15.271844] alsa_open:355 opening device at: 44100
    [19:12:15.272097] alsa_open:411 unable to open audio device requested format: S24_LE
    [19:12:15.272110] decode_init:129 init decode, include codecs:  exclude codecs:
    [19:12:15.272154] register_dsd:624 using dsd to decode dsf,dff
    [19:12:15.281812] load_ff:621 loaded libavcodec.so.56 (56.1.0)
    [19:12:15.281840] load_ff:638 loaded libavformat.so.56 (56.1.0)
    [19:12:15.281849] load_ff:652 loaded libavutil.so.54 (54.3.0)
    [19:12:15.283107] register_ff:731 using ffmpeg to decode alc
    [19:12:15.283122] register_ff:715 using ffmpeg to decode wma,wmap,wmal
    [19:12:15.283235] load_faad:610 loaded libfaad.so.2
    [19:12:15.283246] register_faad:640 using faad to decode aac
    [19:12:15.283333] load_vorbis:300 loaded libvorbisfile.so.3
    [19:12:15.283344] register_vorbis:329 using vorbis to decode ogg
    [19:12:15.283482] load_flac:258 loaded libFLAC.so.8
    [19:12:15.283493] register_flac:286 using flac to decode flc
    [19:12:15.283501] register_pcm:392 using pcm to decode aif,pcm
    [19:12:15.283578] load_mad:383 loaded libmad.so.0
    [19:12:15.283588] register_mad:412 using mad to decode mp3
    [19:12:15.283653] discover_server:756 sending discovery
    [19:12:15.284538] discover_server:767 got response from: 192.168.178.21:3483
    [19:12:15.284558] slimproto:849 connecting to 192.168.178.21:3483
    [19:12:15.285275] slimproto:882 connected
    [19:12:15.285286] sendHELO:124 mac: 50:e5:49:cc:b4:29
    [19:12:15.285293] sendHELO:126 cap: Model=squeezelite,AccuratePlayPoints=1,HasDigitalOut=1,HasPolarityInversion=1,Firmware=v1.8,ModelName=SqueezeLite,MaxSampleRate=384000,dsf,dff,alc,wma,wmap,wmal,aac,ogg,flc,aif,pcm,mp3
    [19:12:15.337493] process:494 strm
    [19:12:15.337505] process_strm:256 strm command q
    [19:12:15.337511] decode_flush:190 decode flush
    [19:12:15.337516] output_flush:423 flush output buffer
    [19:12:15.337522] sendSTAT:171 STAT: STMf
    [19:12:15.337583] process:494 strm
    [19:12:15.337591] process_strm:256 strm command q
    [19:12:15.337596] decode_flush:190 decode flush
    [19:12:15.337602] output_flush:423 flush output buffer
    [19:12:15.337607] sendSTAT:171 STAT: STMf
    [19:12:15.337646] process:494 setd
    [19:12:15.337666] process:494 setd
    [19:12:15.337740] process:494 aude
    [19:12:15.337748] process_aude:395 enable spdif: 1 dac: 1
    [19:12:15.337815] process:494 audg
    [19:12:15.337823] process_audg:413 audg gainL: 65536 gainR: 65536 adjust: 0
    [19:12:15.337829] set_volume:246 setting internal gain left: 65536 right: 65536
    [19:12:20.101210] process:494 strm
    [19:12:20.101221] process_strm:256 strm command t
    [19:12:20.101227] sendSTAT:171 STAT: STMt
    [19:12:20.272114] output_thread:638 open output device: front:CARD=J20,DEV=0
    [19:12:20.272151] alsa_open:355 opening device at: 44100
    [19:12:20.272371] alsa_open:411 unable to open audio device requested format: S24_LE
    [19:12:25.101606] process:494 strm
    [19:12:25.101618] process_strm:256 strm command t
    [19:12:25.101623] sendSTAT:171 STAT: STMt
    [19:12:25.272382] output_thread:638 open output device: front:CARD=J20,DEV=0
    [19:12:25.272406] alsa_open:355 opening device at: 44100
    [19:12:25.272578] alsa_open:411 unable to open audio device requested format: S24_LE
    [19:12:28.869250] slimproto_stop:920 slimproto stop
    Il perché non funziona non saprei dirti (neanche a me funziona)...non riesce ad aprire il device con i 24 bit

    forse qua ci puó aiutare Paolo

  2. #322
    tebibyte L'avatar di bigtube
    Registrato
    May 2012
    Località
    cagliari
    Età
    66
    Messaggi
    2,255
    configurazione

    Predefinito

    Originariamente inviato da antonellocaroli
    Il perché non funziona non saprei dirti (neanche a me funziona)...non riesce ad aprire il device con i 24 bit

    forse qua ci puó aiutare Paolo
    a me parte e suona con il comando di Fabrizio.....pero' io ho messo f:32....andava ovviamente anche f:24. Inoltre -p 97 giova assai anzichè -p 45
    Aldilà di questo comunque viene fuori un suono con Debian da rimanere attoniti....

    PS: Filippo ma non sara' il caso che usi la vecchia JLsounds Transport
    player1:thin client+voyage - player2:futros450+Debian > Usb Transport: I2soverUSB + DAC (6x1704+I/V a tubi) - Attenuatore passivo Lightspeed
    Ampli finale: OTL 6C33 - MyRef Fremen Ed. - Diff.: Diapason Adamantes II - Guida LMS+Squeezelite - B

  3. #323
    tebibyte
    Registrato
    Aug 2011
    Età
    47
    Messaggi
    2,917
    configurazione

    Predefinito

    Originariamente inviato da bigtube
    a me parte e suona con il comando di Fabrizio.....pero' io ho messo f:32....andava ovviamente anche f:24. Inoltre -p 97 giova assai anzichè -p 45
    Aldilà di questo comunque viene fuori un suono con Debian da rimanere attoniti....
    Giova parte perché non prende il comando....e quindi parte, o almeno non lo prende nel modo giusto

    b:20:p:3:f:24
    con questo va anche f:99

    codice:
    8] output_init_alsa:846 requested alsa_buffer: 0 alsa_period: 20 format: p mmap: 1
    Come vedi con quel comando
    alsa buffer 0
    alsa period 20
    format p


    Che parte non significa che funziona come chiesto o come si vorebbe che partisse

    Questo é quello giusto (-a 20:3:24)

    codice:
    19:12:15.267869] output_init_alsa:846 requested alsa_buffer: 20 alsa_period: 3 format: 24 mmap: 1
    Ultima modifica di antonellocaroli : 20-10-2015 a 20:24

  4. #324
    tebibyte L'avatar di bigtube
    Registrato
    May 2012
    Località
    cagliari
    Età
    66
    Messaggi
    2,255
    configurazione

    Predefinito

    Originariamente inviato da antonellocaroli
    Giova parte perché non prende il comando....e quindi parte, o almeno non lo prende nel modo giusto

    b:20:p:3:f:24
    con questo va anche f:99

    codice:
    8] output_init_alsa:846 requested alsa_buffer: 0 alsa_period: 20 format: p mmap: 1

    Che parte non significa che funziona come chiesto o come si vorebbe che partisse

    Questo é quello giusto (-a 20:3:24)

    codice:
    19:12:15.267869] output_init_alsa:846 requested alsa_buffer: 20 alsa_period: 3 format: 24 mmap: 1
    la verita' e che hai perfettamente ragione e personalmente ho usato il tuo modo di inserire la stringa come avevamo in altre occasioni fatto e che consideravo acquisito....insomma io
    ho messo solo i numeri. Non sono stato attento alla tua frase quando hai detto non parte e ho guardato un po' distrattamente il tuo debug.....mi dimentico sempre della tua precisione
    quasi mitica.
    Fabrizio certamente rifletterà sulla questione in modo appropriato grazie al tuo contributo......io facevo meglio a tacere probabilmente....
    player1:thin client+voyage - player2:futros450+Debian > Usb Transport: I2soverUSB + DAC (6x1704+I/V a tubi) - Attenuatore passivo Lightspeed
    Ampli finale: OTL 6C33 - MyRef Fremen Ed. - Diff.: Diapason Adamantes II - Guida LMS+Squeezelite - B

  5. #325
    gibibyte L'avatar di DacPassion
    Registrato
    Jul 2014
    Messaggi
    1,247

    Predefinito

    Originariamente inviato da UnixMan
    Paolo, secondo te per prepararmi una chiavetta per poi installare debian posso usare questa procedura?

    https://it.opensuse.org/SDB:Creare_u...zando_Mac_OS_x
    Clearaudio Emotion + Satisfy + Grado Gold1 > Phono D3A DIY
    Futro S450 + Daphile / Amanero + Buffalo 2 (trident) uscita a TU Cinemag 15/15B DIY / Jlsounds + Lector Digicode TDA1541 S1
    Monoblocchi D3A 2A3 (electrolytich free!!) DIY / Coral Beta8 in BLH DIY

  6. #326
    byte L'avatar di blueray
    Registrato
    Oct 2015
    Messaggi
    172
    configurazione

    Predefinito

    Molto bene vedo che vi siete messi all opera con il tuning di squeezelite e visto che simao in tena io proprrei di aggiungere al file rc.local anche il parametro Alsa "nrpacks" io ho messo il valore 10 ovvero "modprobe snd-usb-audio nrpacks=10" però si può fare dei test con altri valori che possono andare da 1 a 20.

  7. #327
    tebibyte L'avatar di bigtube
    Registrato
    May 2012
    Località
    cagliari
    Età
    66
    Messaggi
    2,255
    configurazione

    Predefinito

    Mi rivolgo a Paolo per la questione Autostart di Squeezelite al reboot:
    ho risolto piazzando prima di ogni stringa immessa nel file rc.local la stringa
    codice:
    sleep 20
    e lasciando il resto uguale.....a dir la verita' ho anche aggiunto, dopo quella di squeezelite, la stringa
    codice:
    modprobe snd-usb-audio nrpacks=10
    di cui ha parlato blueray
    questa stringa del modulo ALSA dovrebbe essere, nei kernel piu' aggiornati, disattesa quindi ininfluente
    Tuttavia dando il comando
    codice:
    dmesg
    mi aspettavo che fosse disattesa e invece non ne ho trovato traccia.....i casi sono due: è accolta e funge oppure proprio non parte come impartito nel file rc.local
    Sta di fatto che ho risolto e ora mi godo pienamente una prestazione (Debian+squeezelite-mc2-i386) davvero impressionante......Daphile si è nascosto....boh ...dov'è!!

    Ps: sleep è un piccolo artificio per far partire il file rc
    Ultima modifica di bigtube : 20-10-2015 a 23:46
    player1:thin client+voyage - player2:futros450+Debian > Usb Transport: I2soverUSB + DAC (6x1704+I/V a tubi) - Attenuatore passivo Lightspeed
    Ampli finale: OTL 6C33 - MyRef Fremen Ed. - Diff.: Diapason Adamantes II - Guida LMS+Squeezelite - B

  8. #328
    byte L'avatar di blueray
    Registrato
    Oct 2015
    Messaggi
    172
    configurazione

    Predefinito

    Giovanni, forse sarebbe meglio riguardoal comando "sleep", di mettere in fondo a rc.local: sleep 20 /etc/init.d/ rtirq start
    Ultima modifica di blueray : 20-10-2015 a 23:46

  9. #329
    tebibyte L'avatar di UnixMan
    Registrato
    Sep 2013
    Messaggi
    2,511
    configurazione

    Predefinito

    Originariamente inviato da DacPassion
    Paolo, secondo te per prepararmi una chiavetta per poi installare debian posso usare questa procedura?

    https://it.opensuse.org/SDB:Creare_u...zando_Mac_OS_x
    Da riga di comando con "dd"? Penso proprio di sì. Se vai a leggere nelle FAQ che ho postato, uno dei metodi consigliati per farlo da linux è proprio quello. Ovviamente, se hai quel comando, puoi farlo anche da OS/X.
    Ciao, Paolo.

    «Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee.»

  10. #330
    tebibyte L'avatar di bigtube
    Registrato
    May 2012
    Località
    cagliari
    Età
    66
    Messaggi
    2,255
    configurazione

    Predefinito

    addenda per l'autostart di S.
    a parte posizionare sleep 10 (adesso basta 10 anzichè 20) prima di tutte le stringhe
    ho constatato che la stringa di S. bisogna metterla in fondo prima di exit 0 altrimenti
    il player non lavora piu' gapless . Dopo un brano si fermava. adesso è tutto OK


    ps: ufff finalmente
    player1:thin client+voyage - player2:futros450+Debian > Usb Transport: I2soverUSB + DAC (6x1704+I/V a tubi) - Attenuatore passivo Lightspeed
    Ampli finale: OTL 6C33 - MyRef Fremen Ed. - Diff.: Diapason Adamantes II - Guida LMS+Squeezelite - B

Informazioni Thread

Users Browsing this Thread

Ci sono attualmente 1 utenti che stanno visualizzando questa discussione. (0 utenti e 1 ospiti)

Regole d'invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
nexthardware.com - © 2002-2018

Search Engine Optimization by vBSEO 3.6.1