Like Tree324Likes

Guida a Logitech Media Server, Squeezelite e derivati.

Pagina 128 di 187
prima
... 28 78 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 178 ... ultimo
Visualizzazione dei risultati da 1,271 a 1,280 su 1861
  1. #1271
    pebibyte L'avatar di marcoc1712
    Registrato
    Jan 2013
    Messaggi
    5,240
    configurazione

    Predefinito

    Originariamente inviato da bigtube
    Marco stai affermando che stiamo deliberatamente complicando le cose . Non è giusto mettere questo marchio . Stai perdendo la pazienza con le persone sbagliate.
    Mi dispiace.....ma l'iniziativa sta partendo da te e se vuoi proseguire in solitaria hai tutto il diritto di farlo.
    quello che tu percepisci come un ostacolo e un fallimento non è legato alla volonta' di alcuno.
    Il crollo del castello lo stai decidendo tu o meglio ritieni che abbiamo costruito un castello di sabbia e corri ai ripari indicandoci come dei confusionari e incapaci.
    Sara' anche vero....ma una mano te l'abbiamo data.....un po' ho la sensazione di essere stato strumentalizzato....dimmi che sono fuori strada alla grande per favore.
    Le derive autocentriche temo stiano venendo fuori . Purtroppo un po' lo temevo e lo prevedevo. Non siamo il tuo team evidentemente . Tua scelta ....non prevedibile all'inizio
    perchè pensavo a tutt'altro
    Per favore fermiamoci qui.
    Mi fa molto male leggere quello che scrivi. Facciamo così, Squeezelite-R2 e C-3PO sono vostri, fatene qello che volete.
    Ciao, Marco.

    "Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius -- and a lot of courage -- to move in the opposite direction."
    — E. F. Schumacher (mis-attributed to A. Einstein)
    ________________________________________________________________________________
    Autore della patch R2 per Squeezelite e del plugin C-3PO. note libere
    Logitech media Server 7.9 > miniPc + squeezelite-R2 / SB+ > "Lu Scalmentu" NOS R2R DAC by TubeOne/ AudioResearch DAC 1-20 >
    Klimo Merlino Gold TPS > DIS Interconnect > Kent Gold > Reference > Monitor Audio Studio 20 SE

  2. #1272
    tebibyte L'avatar di UnixMan
    Registrato
    Sep 2013
    Messaggi
    2,511
    configurazione

    Predefinito

    Originariamente inviato da bhoga
    Log di Squezelite in Daphile (che funziona benissimo)

    /usr/bin/squeezelite -b 3072:4096 -R -u vME:::28 -m 5a:59:64:b6:96:fc -x -c flac,pcm,mp3,ogg,dsd -r 44100,48000,88200,96000,176400,192000 -d all=info -f /run/spacd/c/1/l/0/squeezelite.log -N /mnt/hdd/system/spac/NAD USB Audio 2.0/device0/squeezelite.name -s 192.168.1.110 -o plughw:1,0 -a 100:3:32:1 -p 45
    [...]
    [14:55:41.129542] alsa_open:455 opened device plughw:1,0 using format: S32_LE sample rate: 44100 mmap: 1
    [...]
    guarda caso, usa il device "plughw:1,0", cioè la prima interfaccia della SECONDA "scheda audio" (la numerazione parte da zero), utilizzando "plug".

    A questo punto, su Debian, se stai usando i pacchetti non ti resta che provare a specificare:

    SL_SOUNDCARD="plughw:1,0"

    nel file /etc/default/squeezelite, oppure aggiungere proprio l'opzione "-o plughw:1,0" alla riga di comando con cui lanci squeezelite se stai usando il binario scaricato da github.

    Prima di questo, però, ti consiglierei di dare i comandi:
    codice:
    aplay -l
    aplay -L
    squeezelite -l
    e postare qui i risultati, nonché:
    codice:
    aplay -D plughw:1,0 /usr/share/sounds/alsa/*.wav
    aplay -D hw:1,0 /usr/share/sounds/alsa/*.wav
    ...e verificare che senti quello che devi sentire e/o postare qui eventuali msg di errore.

    Garda caso, guardate cosa succede sul mio sistema (con USB->I2S DIYINHK, vista come hw:0,0) con il secondo comando:
    codice:
     aplay -D hw:0,0 /usr/share/sounds/alsa/*.wav
    Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
    aplay: set_params:1239: Channels count non available
    (le tracce sono mono, l'interfaccia stereo... hw: non converte). Al contrario, con il primo:
    codice:
    aplay -D plughw:0,0 /usr/share/sounds/alsa/*.wav
    Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
    Playing WAVE '/usr/share/sounds/alsa/Front_Left.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
    Playing WAVE '/usr/share/sounds/alsa/Front_Right.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
    Playing WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
    Playing WAVE '/usr/share/sounds/alsa/Rear_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
    Playing WAVE '/usr/share/sounds/alsa/Rear_Left.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
    Playing WAVE '/usr/share/sounds/alsa/Rear_Right.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
    Playing WAVE '/usr/share/sounds/alsa/Side_Left.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
    Playing WAVE '/usr/share/sounds/alsa/Side_Right.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
    funziona perfettamente (perché "plug" converte da mono a stereo, mappando i canali e duplicando lo stream come necessario).
    Ciao, Paolo.

    «Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee.»

  3. #1273
    tebibyte L'avatar di UnixMan
    Registrato
    Sep 2013
    Messaggi
    2,511
    configurazione

    Predefinito

    Originariamente inviato da bigtube
    @Paolo quindi anche tu mi stai bacchettando....e di converso pure Filippo?
    per carità, io non "bacchetto" nessuno. Stavo solo cercando di spiegare quello che so, dare una mano... e ridurre la confusione.

    Se vogliamo, l'unica "bacchettata" che vorrei dare è relativa proprio all'eccessivo affannarsi, al dare troppe risposte diverse e troppo in fretta, che crea solo confusione in chi legge ed è quanto mai controproducente.

    In modo particolare, prima di suggerire qualcosa di "completamente" diverso, aspettate almeno che il diretto interessato abbia avuto modo di provare il suggerimento precedente, e di rispondere. Solo a quel punto si può ragionare -con calma- se sia il caso di provare strade diverse. La fretta è una pessima consigliera.

    @Giovanni, Marco e tutti:

    Per favore, C A L M A ! ! !

    Non c'è nessun motivo di agitarsi, né tanto meno di adirarsi l'un con l'altro. Andiamo avanti, un passo dopo l'altro... con calma, pazienza, armonia, serenità... e tutto il tempo che ci vuole.
    Ciao, Paolo.

    «Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee.»

  4. #1274
    pebibyte L'avatar di marcoc1712
    Registrato
    Jan 2013
    Messaggi
    5,240
    configurazione

    Predefinito

    Originariamente inviato da bhoga
    P.S.
    Superfluo dire che vi sto seguendo e posto per puro spirito di servizio, oltre che per curiosità e voglia di apprendere qualcosina, altrimenti fosse per me mi accontento di Daphile e LMS, che con il plugin di Marco vanno alla grande.
    Quindi se è per me, non c'è nessun affanno a risolvere la questione o far funzionare il sistema, funziona già tutto bene così com'è con Daphile. Se però il fine è creare un sistema aperto, non proprietario, facile da installare e da gestire anche per i principianti come il sottoscritto, allora mi sembra che valga la pena di affrontarlo con spirito ludico e molta calma.....
    Quando avete fatto irruzione sul forum di VHF, scacciati in malo modo da quel buzzurro, pensavo aveste già approntato un sistema a prova di incapace. Forse non era così e ve ne siete resi conto ora. Ma non mi sembra un buon motivo per buttare tutto all'aria....
    Quanto a me, lo faccio volentieri, tempo permettendo e finchè dura la voglia di aiutare come posso, ma ditemi voi: non ho problemi a stare alla finestra...

    Ah, dimenticavo, stamattina prima di andarmene in giro ho messo in fabbricazione una Debian 32 bit: quindi la versione "vergine" ora c'è...
    @bhoga se vuoi farmi un favore, prova sulla Debian 32 vergine il seguente comando (è leggermente modificato rispetto a quello di Daphile):

    ./squeezelite-R2 -b 3072:4096 -r 44100,48000,88200,96000,176400,192000 -x -d all=info -f /var/log/squeezelite-R2-151220.log -n Squeezelite-R2@debian32 -o plughw:1,0 -a 100:3:32:1 -p 45

    a quel punto, dovrebbe comparirti il lettore in LMS (Squeezelite-R2@debian32) selezionalo e prova ad inviargli in play un file FLAC normale e per favore posta il contenuto del file /var/log/squeezelite-R2-151220.log

    Se va, ok, se non va, l'unica ulteriore prova sensata da fare (ma sarebbe strano) è abbassare il bit depth in LMS-> Impostazioni -> Avanzate da 32 a 24 o 16, se non lo hai già fatto (ricorsati di salvare, rifarlo e salvare di nuovo, quindi di riavviare il server, qui c'è un buco...)

    Se ancora non dovesse andare, vediamo cosa dice ALSA e ne convengo a quel punto sarebbe molto meglio operare come propone Paolo, con tool esterni a Squezelite, così da capire se ALSA in Debian funziona o meno con la tua scheda, restringendo sempre più il campo e la pertinenza dello specifico problema.

    Grazie.
    Ciao, Marco.

    "Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius -- and a lot of courage -- to move in the opposite direction."
    — E. F. Schumacher (mis-attributed to A. Einstein)
    ________________________________________________________________________________
    Autore della patch R2 per Squeezelite e del plugin C-3PO. note libere
    Logitech media Server 7.9 > miniPc + squeezelite-R2 / SB+ > "Lu Scalmentu" NOS R2R DAC by TubeOne/ AudioResearch DAC 1-20 >
    Klimo Merlino Gold TPS > DIS Interconnect > Kent Gold > Reference > Monitor Audio Studio 20 SE

  5. #1275
    tebibyte L'avatar di bigtube
    Registrato
    May 2012
    Località
    cagliari
    Età
    66
    Messaggi
    2,255
    configurazione

    Predefinito

    Originariamente inviato da UnixMan
    per carità, io non "bacchetto" nessuno. Stavo solo cercando di spiegare quello che so, dare una mano... e ridurre la confusione.

    Se vogliamo, l'unica "bacchettata" che vorrei dare è relativa proprio all'eccessivo affannarsi, al dare troppe risposte diverse e troppo in fretta, che crea solo confusione in chi legge ed è quanto mai controproducente.

    In modo particolare, prima di suggerire qualcosa di "completamente" diverso, aspettate almeno che il diretto interessato abbia avuto modo di provare il suggerimento precedente, e di rispondere. Solo a quel punto si può ragionare -con calma- se sia il caso di provare strade diverse. La fretta è una pessima consigliera.

    @Giovanni, Marco e tutti:

    Per favore, C A L M A ! ! !

    Non c'è nessun motivo di agitarsi, né tanto meno di adirarsi l'un con l'altro. Andiamo avanti, un passo dopo l'altro... con calma, pazienza, armonia, serenità... e tutto il tempo che ci vuole.
    Non hai tutti i torti... sarebbe anche inutile dire che ci saremmo arrivati viste le possibili vie che permette ALSA. Ma si da' il caso che le possibilita' di incespicare sono tante e il giro bisogna farselo
    quando c'è il problema. tuttavia dire che si crea confusione e accusare di rovinare il lavoro altrui è abbastanza inaccettabile. Io non voglio la paternita' di nulla . Ho ricevuto l'imprimatur di inadeguato
    e che sia vero o no ha ormai poca importanza.
    Troppo entusiasmo puo' essere ridotto in fumo in un batter d'occhi. Ho fatto del mio meglio e se ho fallito è sicuramente per colpa della mia inettitudine. E' un po' triste doverlo constatare ma voi
    lo avete decretato. Non mi ribello, non perdo la calma. Prendo atto....visto che non c'è nessun appello. Le parole pesano e se non si riflette bene possono fare danni. Ognuno guardi in casa sua.
    player1:thin client+voyage - player2:futros450+Debian > Usb Transport: I2soverUSB + DAC (6x1704+I/V a tubi) - Attenuatore passivo Lightspeed
    Ampli finale: OTL 6C33 - MyRef Fremen Ed. - Diff.: Diapason Adamantes II - Guida LMS+Squeezelite - B

  6. #1276
    nibble L'avatar di bhoga
    Registrato
    Dec 2015
    Età
    61
    Messaggi
    66

    Predefinito

    Originariamente inviato da marcoc1712
    @bhoga se vuoi farmi un favore, prova sulla Debian 32 vergine il seguente comando (è leggermente modificato rispetto a quello di Daphile):

    ./squeezelite-R2 -b 3072:4096 -r 44100,48000,88200,96000,176400,192000 -x -d all=info -f /var/log/squeezelite-R2-151220.log -n Squeezelite-R2@debian32 -o plughw:1,0 -a 100:3:32:1 -p 45

    a quel punto, dovrebbe comparirti il lettore in LMS (Squeezelite-R2@debian32) selezionalo e prova ad inviargli in play un file FLAC normale e per favore posta il contenuto del file /var/log/squeezelite-R2-151220.log

    Se va, ok, se non va, l'unica ulteriore prova sensata da fare (ma sarebbe strano) è abbassare il bit depth in LMS-> Impostazioni -> Avanzate da 32 a 24 o 16, se non lo hai già fatto (ricorsati di salvare, rifarlo e salvare di nuovo, quindi di riavviare il server, qui c'è un buco...)

    Se ancora non dovesse andare, vediamo cosa dice ALSA e ne convengo a quel punto sarebbe molto meglio operare come propone Paolo, con tool esterni a Squezelite, così da capire se ALSA in Debian funziona o meno con la tua scheda, restringendo sempre più il campo e la pertinenza dello specifico problema.

    Grazie.
    Ho seguito questi comandi:
    wget 'https://github.com/marcoc1712/squeezelite-R2/releases/download/v1.8.1-(R2)/squeezelite-R2-i386'
    chmod ug+x squeezelite-R2-i386

    Inserendo il tuo comandoo: ./squeezelite-R2 -b 3072:4096 -r 44100,48000,88200,96000,176400,192000 -x -d all=info -f /var/log/squeezelite-R2-151220.log -n Squeezelite-R2@debian32 -o plughw:1,0 -a 100:3:32:1 -p 45 non trova squeezelite-R2

    Modificandolo così: ./squeezelite-R2-i386 -b 3072:4096 -r 44100,48000,88200,96000,176400,192000 -x -d all=info -f /var/log/squeezelite-R2-151220.log -n Squeezelite-R2-i386@debian32 -o plughw:1,0 -a 100:3:32:1 -p 45 la risposta è: error while loading shared libraries: libasound.so.2: cannot open shared object file: No such file or directory

  7. #1277
    tebibyte L'avatar di UnixMan
    Registrato
    Sep 2013
    Messaggi
    2,511
    configurazione

    Predefinito

    Giovanni, Marco: capisco che, come purtroppo spesso capita quando ci si trova a discutere a distanza davanti ad un monitor ed una tastiera, si sono creati malintesi e sono anche volate parole piuttosto "pesanti" e spiacevoli. Sono sicuro che se ci fossimo trovati tutti insieme, di persona, non sarebbe mai successo nulla del genere. Personalmente non credo che nessuno abbia veramente inteso criticare te o Marco, né tanto meno tutto l'eccellente lavoro che avete svolto entrambi. Non lasciamo che un incidente causato principalmente dalle peculiarità e dalla limitatezza del mezzo che usiamo per comunicare rovini tutto quanto fatto finora.

    Cosa forse ancora più importante, non lasciamo che questo incidente possa guastare i vostri/nostri rapporti, nonché un ambiente, quello di questo forum, che finora è stato un'oasi tranquilla e felice e dove, nonostante le diverse idee ed opinioni e le inevitabili piccole o grandi divergenze che ne conseguono, siamo sempre riusciti ad andare avanti serenamente e senza conflitti.

    Se non fossimo così distanti vi inviterei a bere qualcosa, a stringervi/ci la mano ed a riderci su. Pur non potendolo fare materialmente, vi invito lo stesso a farlo almeno... "virtualmente".
    Ciao, Paolo.

    «Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee.»

  8. #1278
    tebibyte L'avatar di bigtube
    Registrato
    May 2012
    Località
    cagliari
    Età
    66
    Messaggi
    2,255
    configurazione

    Predefinito

    Originariamente inviato da bhoga
    Ho seguito questi comandi:
    wget 'https://github.com/marcoc1712/squeezelite-R2/releases/download/v1.8.1-(R2)/squeezelite-R2-i386'
    chmod ug+x squeezelite-R2-i386

    Inserendo il tuo comandoo: ./squeezelite-R2 -b 3072:4096 -r 44100,48000,88200,96000,176400,192000 -x -d all=info -f /var/log/squeezelite-R2-151220.log -n Squeezelite-R2@debian32 -o plughw:1,0 -a 100:3:32:1 -p 45 non trova squeezelite-R2

    Modificandolo così: ./squeezelite-R2-i386 -b 3072:4096 -r 44100,48000,88200,96000,176400,192000 -x -d all=info -f /var/log/squeezelite-R2-151220.log -n Squeezelite-R2-i386@debian32 -o plughw:1,0 -a 100:3:32:1 -p 45 la risposta è: error while loading shared libraries: libasound.so.2: cannot open shared object file: No such file or directory
    verifica che sia installato libasound2
    apt-get install libasound2

    libasound2 fa' parte delle dipendenze e non libasound.so.2
    UnixMan likes this.
    player1:thin client+voyage - player2:futros450+Debian > Usb Transport: I2soverUSB + DAC (6x1704+I/V a tubi) - Attenuatore passivo Lightspeed
    Ampli finale: OTL 6C33 - MyRef Fremen Ed. - Diff.: Diapason Adamantes II - Guida LMS+Squeezelite - B

  9. #1279
    nibble L'avatar di bhoga
    Registrato
    Dec 2015
    Età
    61
    Messaggi
    66

    Predefinito

    Installata la libreria, ora:

    root@debian:/home/fab# ./squeezelite-R2-i386 -b 3072:4096 -r 44100,48000,88200,96000,176400,192000 -x -d all=info -f /var/log/squeezelite-R2-151220.log -n Squeezelite-R2-i386@debian32 -o plughw:1,0 -a 100:3:32:1 -p 45

    Option error: -x

  10. #1280
    tebibyte L'avatar di UnixMan
    Registrato
    Sep 2013
    Messaggi
    2,511
    configurazione

    Predefinito

    Originariamente inviato da bigtube
    verifica che sia installato libasound2
    apt-get install libasound2

    libasound2 fa' parte delle dipendenze e non libasound.so.2
    sì: la libreria "libasound.so.2" fa parte del (è installata dal) pacchetto libasound2. Installare quella libreria (ed altro, tra cui in particolare "alsa-utils") è una delle cose che fa lo script.
    Ciao, Paolo.

    «Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee.»

Informazioni Thread

Users Browsing this Thread

Ci sono attualmente 1 utenti che stanno visualizzando questa discussione. (0 utenti e 1 ospiti)

Regole d'invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
nexthardware.com - © 2002-2018

Search Engine Optimization by vBSEO 3.6.1