Like Tree324Likes

Guida a Logitech Media Server, Squeezelite e derivati.

Pagina 125 di 187
prima
... 25 75 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 175 ... ultimo
Visualizzazione dei risultati da 1,241 a 1,250 su 1861
  1. #1241
    pebibyte L'avatar di marcoc1712
    Registrato
    Jan 2013
    Messaggi
    5,240
    configurazione

    Predefinito

    Originariamente inviato da bhoga
    Il kernel ora Ŕ questo: 3.16.0-4-686-pae, il custom Ŕ permanentemente commentato, con "alsamixer" risponde come sempre mi Ŕ successo finora a 32 e 64 bit (anche col kernel liquorix precedente): cannot open mixer: File o directory non esistente.
    Con alsamixer -c1 in questo kernel appare solo il clock del Nad, nel precedente l'intero mixer. LMS trova il lettore (debian), come sempre non esce musica.
    Ecco la parte finale del log di squeezelite (se serve domani posso inviarlo via mail):

    [23:40:07.782420] ALSA _snd_config_evaluate:4259 function snd_func_concat returned error: No such file or directory
    [23:40:07.782444] ALSA snd_func_refer:1251 error evaluating name
    [23:40:07.782467] ALSA _snd_config_evaluate:4259 function snd_func_refer returned error: No such file or directory
    [23:40:07.782493] ALSA snd_config_expand:4738 Evaluate error: No such file or directory
    [23:40:07.782527] ALSA snd_pcm_open_noupdate:2239 Unknown PCM default
    [23:40:07.782549] output_thread:631 waiting for device default to return
    [23:40:12.782928] ALSA parse_card:768 cannot find card '0'
    [23:40:12.783024] ALSA _snd_config_evaluate:4259 function snd_func_card_driver returned error: No such file or directory
    [23:40:12.783088] ALSA snd_func_concat:392 error evaluating strings
    [23:40:12.783114] ALSA _snd_config_evaluate:4259 function snd_func_concat returned error: No such file or directory
    [23:40:12.783137] ALSA snd_func_refer:1251 error evaluating name
    [23:40:12.783159] ALSA _snd_config_evaluate:4259 function snd_func_refer returned error: No such file or directory
    [23:40:12.783182] ALSA snd_config_expand:4738 Evaluate error: No such file or directory
    [23:40:12.783215] ALSA snd_pcm_open_noupdate:2239 Unknown PCM default
    [23:40:12.783235] output_thread:631 waiting for device default to return
    [23:40:17.783572] ALSA parse_card:768 cannot find card '0'
    [23:40:17.783666] ALSA _snd_config_evaluate:4259 function snd_func_card_driver returned error: No such file or directory
    [23:40:17.783692] ALSA snd_func_concat:392 error evaluating strings
    [23:40:17.783714] ALSA _snd_config_evaluate:4259 function snd_func_concat returned error: No such file or directory
    [23:40:17.783737] ALSA snd_func_refer:1251 error evaluating name
    [23:40:17.783758] ALSA _snd_config_evaluate:4259 function snd_func_refer returned error: No such file or directory
    [23:40:17.783781] ALSA snd_config_expand:4738 Evaluate error: No such file or directory
    [23:40:17.783813] ALSA snd_pcm_open_noupdate:2239 Unknown PCM default
    [23:40:17.783833] output_thread:631 waiting for device default to return
    [23:40:22.784179] ALSA parse_card:768 cannot find card '0'
    [23:40:23.849729] ALSA _snd_config_evaluate:4259 function snd_func_card_driver returned error: No such file or directory
    [23:40:23.849778] ALSA snd_func_concat:392 error evaluating strings
    [23:40:23.849801] ALSA _snd_config_evaluate:4259 function snd_func_concat returned error: No such file or directory
    [23:40:23.849823] ALSA snd_func_refer:1251 error evaluating name
    [23:40:23.849845] ALSA _snd_config_evaluate:4259 function snd_func_refer returned error: No such file or directory
    [23:40:23.849869] ALSA snd_config_expand:4738 Evaluate error: No such file or directory
    [23:40:23.849905] ALSA snd_pcm_open_noupdate:2239 Unknown PCM default
    [23:40:23.849925] output_thread:631 waiting for device default to return
    [23:40:28.850216] ALSA parse_card:768 cannot find card '0'
    [23:40:28.850301] ALSA _snd_config_evaluate:4259 function snd_func_card_driver returned error: No such file or directory
    [23:40:28.850326] ALSA snd_func_concat:392 error evaluating strings

    Abbastanza per oggi... :-). Caso mai ci sentiamo domani...

    Questo pare lo stesso errore che avevo riportato io: Alsa non vede la sound card che invece Ŕ vista come default da squeezelite. Si pu˛ provare a 'forzare' l'uso di una scheda specifica con l'opzione -o, usando possibilmente la stessa in uso con Daphile (che funziona), ma temo sia un problema pi¨ generico di ALSA qui. E' un'istallazione 'vergine'?

    EDIT: Non avevo visto il commento di Giovanni.
    Ultima modifica di marcoc1712 : 19-12-2015 a 00:59
    Ciao, Marco.

    "Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius -- and a lot of courage -- to move in the opposite direction."
    Ś E. F. Schumacher (mis-attributed to A. Einstein)
    ________________________________________________________________________________
    Autore della patch R2 per Squeezelite e del plugin C-3PO. note libere
    Logitech media Server 7.9 > miniPc + squeezelite-R2 / SB+ > "Lu Scalmentu" NOS R2R DAC by TubeOne/ AudioResearch DAC 1-20 >
    Klimo Merlino Gold TPS > DIS Interconnect > Kent Gold > Reference > Monitor Audio Studio 20 SE

  2. #1242
    tebibyte L'avatar di bigtube
    Registrato
    May 2012
    LocalitÓ
    cagliari
    EtÓ
    66
    Messaggi
    2,255
    configurazione

    Predefinito

    Originariamente inviato da marcoc1712
    Questo pare lo stesso errore che avevo riportato io: Alsa non vede la sound card che invece Ŕ vista come default da squeezelite. Si pu˛ provare a 'forzare' l'uso di una scheda specifica con l'opzione -o, usando possibilmente la stessa in uso con Daphile (che funziona), ma temo sia un problema pi¨ generico di ALSA qui. E' un'istallazione 'vergine'?
    Alsa non si interfaccia con squeezelite....un bel problema.....abbastanza incomprensibile visto che anche Daphile usa kernel aggiornatissimi.
    Comunque bisognerebbe verificare se le dipendenze di squeezelite son tutte soddisfatte. Una procedura d'installazione di ffmpeg potrebbe sistemare
    le dipendenze.
    player1:thin client+voyage - player2:futros450+Debian > Usb Transport: I2soverUSB + DAC (6x1704+I/V a tubi) - Attenuatore passivo Lightspeed
    Ampli finale: OTL 6C33 - MyRef Fremen Ed. - Diff.: Diapason Adamantes II - Guida LMS+Squeezelite - B

  3. #1243
    tebibyte
    Registrato
    Aug 2011
    EtÓ
    47
    Messaggi
    2,917
    configurazione

    Predefinito

    Originariamente inviato da marcoc1712
    Si, Proverei a mandarla in esecuzione e vedere se suona. Non ricordo pi¨ i parametri da da usare con la tua scheda, mi pare:

    ./squeezelite-R2-i386 -r 44100-192000 -d all=debug -f /var/log/squeezelite-R2-151218.log

    dovrebbe bastare, il file di log l'ho rinominato cosý eventualmente riesci a postarlo.

    Grazie.
    con quel comando difficilmente funziona...come spiegato anche da Paolo...non sempre il plug in alsa funziona sopratutto con schede usb...sarebbe meglio forzare l uso della scheda

    Prima di fare quasta prova conviene dare in seguenza questi comandi:
    codice:
    apt-get update
    apt-get upgrade
    apt-get install mpg321 alsa-utils fdupes ffmpeg flac libsox-fmt-all mc sox

    ./squeezelite-R2-i386 -o hw:CARD=N20,DEV=0 -r 44100-192000 -d all=debug -f /var/log/squeezelite-R2-151219.log

    Molto probabilmente non uscirß suono neanche con questo...ma dal log forse si puˇ capire qualcosa in pi˙....

    Magari bhoga se puˇ mandare in play un mp3 anche o na radio....continuo a pensare a problemi di impostazione....

    se fosse un problema di incompatibilitß alsa/scheda-audio dovrebbe presentarsi anche con Daphile....credo
    Ultima modifica di antonellocaroli : 19-12-2015 a 11:14

  4. #1244
    pebibyte L'avatar di marcoc1712
    Registrato
    Jan 2013
    Messaggi
    5,240
    configurazione

    Predefinito

    Originariamente inviato da bigtube
    Alsa non si interfaccia con squeezelite....un bel problema.....abbastanza incomprensibile visto che anche Daphile usa kernel aggiornatissimi.
    Comunque bisognerebbe verificare se le dipendenze di squeezelite son tutte soddisfatte. Una procedura d'installazione di ffmpeg potrebbe sistemare
    le dipendenze.
    mhhh... dal log ffmpeg sembra attivo e funzionante, non pare ci siano problemi di librerie mancanti. Secondo me Ŕ un problema di ALSA, sull'output.
    Ciao, Marco.

    "Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius -- and a lot of courage -- to move in the opposite direction."
    Ś E. F. Schumacher (mis-attributed to A. Einstein)
    ________________________________________________________________________________
    Autore della patch R2 per Squeezelite e del plugin C-3PO. note libere
    Logitech media Server 7.9 > miniPc + squeezelite-R2 / SB+ > "Lu Scalmentu" NOS R2R DAC by TubeOne/ AudioResearch DAC 1-20 >
    Klimo Merlino Gold TPS > DIS Interconnect > Kent Gold > Reference > Monitor Audio Studio 20 SE

  5. #1245
    pebibyte L'avatar di marcoc1712
    Registrato
    Jan 2013
    Messaggi
    5,240
    configurazione

    Predefinito

    Originariamente inviato da antonellocaroli
    con quel comando difficilmente funziona...come spiegato anche da Paolo...non sempre il plug in alsa funziona sopratutto con schede usb...sarebbe meglio forzare l uso della scheda

    Prima di fare quasta prova conviene dare in seguenza questi comandi:
    codice:
    apt-get update
    apt-get upgrade
    apt-get install mpg321 alsa-utils fdupes ffmpeg flac libsox-fmt-all mc sox

    ./squeezelite-R2-i386 -o hw:CARD=N20,DEV=0 -r 44100-192000 -d all=debug -f /var/log/squeezelite-R2-151219.log

    Molto probabilmente non uscirß suono neanche con questo...ma dal log forse si puˇ capire qualcosa in pi˙....

    Magari bhoga se puˇ mandare in play un mp3 anche o na radio....continuo a pensare a problemi di impostazione....

    se fosse un problema di incompatibilitß alsa/scheda-audio dovrebbe presentarsi anche con Daphile....credo
    Stando al log, non ci sono evidenti problemi di mancanza di librerie lato input e/o transcoding. E' il processo di output, l'apertura del device tramite ALSA che fallisce.

    Proverei certamente la forzatura del -o come suggerisce Filippo,

    ./squeezelite-R2-i386 -o hw:CARD=N20,DEV=0 -r 44100-192000 -d all=debug -f /var/log/squeezelite-R2-151219.log

    ma mi sentirei pi¨ tranquillo vedendo l'esatto comando usato da Daphile, dato che funziona, replicato esattamente.


    Proprio perchŔ non si presenta con Daphile, una volta escluse differenze nei parametri di lancio, rimane come unica possibilitÓ un problema con ALSA su questa specifica installazione.

    Non ho ancora capito se Ŕ una versione di debian 'vergine' o se Ŕ quella giÓ oggetto dello script, nel secondo caso, proverei con una versione 'vergine'.


    EDIT:

    @bogha, Per recuperare la riga di lancio di Daphile, su Daphile: Info-> log files -> squeezelite (Wiev).

    La prima riga Ŕ la riga di lancio ed Ŕ quella che ci interessa maggiormante, le altre dovrebbero mostrare il corretto avvio della scheda anche con ALSA. Se riesci a postarlo ci fai un favore.
    Ultima modifica di marcoc1712 : 19-12-2015 a 11:36
    Ciao, Marco.

    "Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius -- and a lot of courage -- to move in the opposite direction."
    Ś E. F. Schumacher (mis-attributed to A. Einstein)
    ________________________________________________________________________________
    Autore della patch R2 per Squeezelite e del plugin C-3PO. note libere
    Logitech media Server 7.9 > miniPc + squeezelite-R2 / SB+ > "Lu Scalmentu" NOS R2R DAC by TubeOne/ AudioResearch DAC 1-20 >
    Klimo Merlino Gold TPS > DIS Interconnect > Kent Gold > Reference > Monitor Audio Studio 20 SE

  6. #1246
    tebibyte L'avatar di bigtube
    Registrato
    May 2012
    LocalitÓ
    cagliari
    EtÓ
    66
    Messaggi
    2,255
    configurazione

    Predefinito

    Originariamente inviato da antonellocaroli
    con quel comando difficilmente funziona...come spiegato anche da Paolo...non sempre il plug in alsa funziona sopratutto con schede usb...sarebbe meglio forzare l uso della scheda

    Prima di fare quasta prova conviene dare in seguenza questi comandi:
    codice:
    apt-get update
    apt-get upgrate
    apt-get install mpg321 alsa-utils fdupes ffmpeg flac libsox-fmt-all mc sox

    ./squeezelite-R2-i386 -o hw:CARD=N20,DEV=0 -r 44100-192000 -d all=debug -f /var/log/squeezelite-R2-151219.log

    Molto probabilmente non uscirß suono neanche con questo...ma dal log forse si puˇ capire qualcosa in pi˙....

    Magari bhoga se puˇ mandare in play un mp3 anche o na radio....continuo a pensare a problemi di impostazione....

    se fosse un problema di incompatibilitß alsa/scheda-audio dovrebbe presentarsi anche con Daphile....credo
    Infatti proponevo proprio questo e il modo migliore Ŕ fare la procedura d'installazione di ffmpeg che in debian obbliga a inserire
    nel file sources.list il repository standard
    quindi:
    nano /etc/apt/sources.list
    si aggiunge :
    codice:
    deb http://www.deb-multimedia.org jessie main non-free
    deb-src  http://www.deb-multimedia.org jessie main non-free
    fatto cio' si da'
    apt-get update
    e quindi
    apt-get install ffmpeg sox libsoxr-fmt-all flac mpg321 fdupes alsa-utils

    Alsa-utils non dovrebbe essere necessario
    per sapere quali dipendenze sono necessarie si da' il comando
    root@debian:~# apt-cache depends squeezelite
    squeezelite
    Dipende: libasound2
    |Dipende: libavcodec56
    Dipende: libavcodec-extra-56
    Dipende: libavformat56
    Dipende: libavutil54
    Dipende: libc6
    Dipende: libfaad2
    Dipende: libflac8
    Dipende: libmad0
    Dipende: libmpg123-0
    Dipende: libsoxr0
    Dipende: libvorbisfile3
    Se si da' questo comando in Daphile la risposta dovrebbe essere quella sopra e io chiederei a bhoga nello stato in cui si trova ora
    di dare questo comando e confrontare con questo che ho postato . Tutto cio' se ha usato lo script non avrebbe senso....pero' ora non
    ricordo se era compreso ffmpeg.

    Comunque anch'io come Filippo darei un altro comando a squeezelite e cioe':
    ./squeezelite-R2-i386 -o front:CARD=N20,DEV=0 -r 44100-192000 -d all=debug -f /var/log/squeezelite-R2-151219.log
    Ultima modifica di bigtube : 19-12-2015 a 11:44
    player1:thin client+voyage - player2:futros450+Debian > Usb Transport: I2soverUSB + DAC (6x1704+I/V a tubi) - Attenuatore passivo Lightspeed
    Ampli finale: OTL 6C33 - MyRef Fremen Ed. - Diff.: Diapason Adamantes II - Guida LMS+Squeezelite - B

  7. #1247
    tebibyte
    Registrato
    Aug 2011
    EtÓ
    47
    Messaggi
    2,917
    configurazione

    Predefinito

    Originariamente inviato da marcoc1712
    Stando al log, non ci sono evidenti problemi di mancanza di librerie lato input e/o transcoding. E' il processo di output, l'apertura del device tramite ALSA che fallisce.
    Questo Ú chiaro e oramai sappiamo anche il perchÚ....quel comando fallisce anche sul mio sistema...probabilmente su qualsiasi sistama debian (o linux) con dac usb...
    comunque un comando da escludere a priori!!!
    infatti il log che ci ha restituito non ci serve a niente.....

    qualcuno mi chiarisce una cosa? se dal server arriva un file PCM a 32 bit Ú il dac non lo sopporta? alsa lo adegua?

    per questo proponevo un play di un mp3 o radio....anche per escludere problemi di configurazione in LMS...

    onde evitare ancora problemi come comando Ú meglio questo

    ./squeezelite-R2-i386 -o hw:CARD=N20,DEV=0 -r 44100-192000 -d all=debug -f /var/log/squeezelite-R2-151219.log
    Ultima modifica di antonellocaroli : 19-12-2015 a 11:48

  8. #1248
    tebibyte L'avatar di bigtube
    Registrato
    May 2012
    LocalitÓ
    cagliari
    EtÓ
    66
    Messaggi
    2,255
    configurazione

    Predefinito

    Originariamente inviato da antonellocaroli
    Questo Ú chiaro e oramai sappiamo anche il perchÚ....quel comando fallisce anche sul mio sistema...probabilmente su qualsiasi sistama debian con dac usb...
    comunque un comando da escludere a priori!!!
    infatti il log che ci ha restituito non ci serve a niente.....

    qualcuno mi chiarisce una cosa? se dal server arriva un file PCM a 32 bit Ú il dac non lo sopporta? alsa lo adegua?

    per questo proponevo un play di un mp3 o radio....anche per escludere problemi di configurazione in LMS...

    onde evitare ancora problemi come comando Ú meglio questo

    ./squeezelite-R2-i386 -o hw:CARD=N20,DEV=0 -r 44100-192000 -d all=debug -f /var/log/squeezelite-R2-151219.log
    ci siamo incrociati Phil
    Pero' io proverei anche con -o front:CARD=0,DEV=0
    player1:thin client+voyage - player2:futros450+Debian > Usb Transport: I2soverUSB + DAC (6x1704+I/V a tubi) - Attenuatore passivo Lightspeed
    Ampli finale: OTL 6C33 - MyRef Fremen Ed. - Diff.: Diapason Adamantes II - Guida LMS+Squeezelite - B

  9. #1249
    tebibyte L'avatar di bigtube
    Registrato
    May 2012
    LocalitÓ
    cagliari
    EtÓ
    66
    Messaggi
    2,255
    configurazione

    Predefinito

    Inoltre per sapere con precisione quale repository deve avere la priorita'
    si da' il comando:
    apt-cache policy squeezelite

    per sapere se ci sono conflitti:
    aptitude why-not squeezelite

    ....Debian lascia poco al caso...

    leggasi qui:
    http://guide.debianizzati.org/index.php/Guida_ai_comandi_da_terminale_-_Gestione_di_repository_e_pacchetti

    In conclusione si deve verificare tutto cio' ....e se poi non funge lo stesso....ve lo dico un'altra volta
    Ultima modifica di bigtube : 19-12-2015 a 12:03
    UnixMan likes this.
    player1:thin client+voyage - player2:futros450+Debian > Usb Transport: I2soverUSB + DAC (6x1704+I/V a tubi) - Attenuatore passivo Lightspeed
    Ampli finale: OTL 6C33 - MyRef Fremen Ed. - Diff.: Diapason Adamantes II - Guida LMS+Squeezelite - B

  10. #1250
    tebibyte
    Registrato
    Aug 2011
    EtÓ
    47
    Messaggi
    2,917
    configurazione

    Predefinito

    Originariamente inviato da marcoc1712
    .
    Non ho ancora capito se Ŕ una versione di debian 'vergine' o se Ŕ quella giÓ oggetto dello script, nel secondo caso, proverei con una versione 'vergine'.
    Marco continui ad andare alla ricerca di fantasmi...se ha usato lo script Ú meglio...evita tutto quello che sta dicendo, giustamente Giovanni, lo script non pregiudica il funzionamento di quelle stringe..o di squeezelite-R2 "standard"..fargli installare una debian vergine di nuovo...significa fare tutte quelle procedure che sta descrivendo Giovanni.

    sinceramente non capisco neanche perchÚ da principio non hai suggerito il comando con -o altro fantasma?
    UnixMan likes this.

Informazioni Thread

Users Browsing this Thread

Ci sono attualmente 2 utenti che stanno visualizzando questa discussione. (0 utenti e 2 ospiti)

Regole d'invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
nexthardware.com - ę 2002-2018

Search Engine Optimization by vBSEO 3.6.1