Like Tree324Likes

Guida a Logitech Media Server, Squeezelite e derivati.

Pagina 123 di 187
prima
... 23 73 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 173 ... ultimo
Visualizzazione dei risultati da 1,221 a 1,230 su 1861
  1. #1221
    pebibyte L'avatar di marcoc1712
    Registrato
    Jan 2013
    Messaggi
    5,240
    configurazione

    Predefinito

    Originariamente inviato da bhoga
    Ecco qua il porello utente medio. ...
    Posso continuare qui a chiedere info o preferite che posti in privato?
    Visto che Daphile è al sicuro ed è tutto settato a puntino, mi sto cimentando con l'installazione di Debian32+squeezelite su pendrive.
    Ho già un problema subito: non riconosce il dispositivo di uscita audio connesso (con la versione a 64 bit il Dac era stato riconosciuto subito).
    La risposta che dà è la seguente:

    Elenco dei dispositivi di uscita audio riconosciuti dal sistema:
    ./easetup.sh: riga 75: aplay: comando non trovato

    Suggerimenti?
    Ben tornato!

    Che privato, tutto in pubblico...
    Visto che stai usando lo script easetup.sh ti lascio nele mani di altri, Paolo (unxman) in primis. Io sono una capra con Linux.
    Ciao, Marco.

    "Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius -- and a lot of courage -- to move in the opposite direction."
    — E. F. Schumacher (mis-attributed to A. Einstein)
    ________________________________________________________________________________
    Autore della patch R2 per Squeezelite e del plugin C-3PO. note libere
    Logitech media Server 7.9 > miniPc + squeezelite-R2 / SB+ > "Lu Scalmentu" NOS R2R DAC by TubeOne/ AudioResearch DAC 1-20 >
    Klimo Merlino Gold TPS > DIS Interconnect > Kent Gold > Reference > Monitor Audio Studio 20 SE

  2. #1222
    tebibyte
    Registrato
    Aug 2011
    Età
    47
    Messaggi
    2,917
    configurazione

    Predefinito

    Originariamente inviato da bhoga
    Ecco qua il porello utente medio. ...
    Posso continuare qui a chiedere info o preferite che posti in privato?
    Visto che Daphile è al sicuro ed è tutto settato a puntino, mi sto cimentando con l'installazione di Debian32+squeezelite su pendrive.
    Ho già un problema subito: non riconosce il dispositivo di uscita audio connesso (con la versione a 64 bit il Dac era stato riconosciuto subito).
    La risposta che dà è la seguente:

    Elenco dei dispositivi di uscita audio riconosciuti dal sistema:
    ./easetup.sh: riga 75: aplay: comando non trovato

    Suggerimenti?
    hai due soluzioni e tutte e due hanno bisogno che prima dai questi comandi

    codice:
    apt-get update
    apt-get install alsa-utils
    strano che non siano giá installate di default

    soluzione 1) Manuale

    codice:
    wget 'https://github.com/marcoc1712/squeezelite-R2/releases/download/v1.8.1-(R2)/squeezelite-R2-i386'
    
    chmod ug+x squeezelite-R2-i386
    
    ./squeezelite-R2-i386 -o front:CARD=N20,DEV=0 -d all=debug
    soluzione 2) script

    codice:
    wget 'http://www.audiofaidate.org/sw/easetup.sh'
    chmod +x easetup.sh
    ./easetup.sh

    @Paolo forse nello script ultimo c´é qualche problema....o quanto meno le alsa-utils devono essere la prima cosa che si installa...
    Ultima modifica di antonellocaroli : 15-12-2015 a 19:50

  3. #1223
    nibble L'avatar di bhoga
    Registrato
    Dec 2015
    Età
    61
    Messaggi
    66

    Predefinito

    Ho provato a fare da me installando manualmente alsa (apt-get install alsa-base alsa-utils alsa-tools) visto che al comando alsamixer, e nemmeno con alsamixer -c 1, non appariva nulla ho pensato che non poteva riconoscere la scheda audio senza questa componente.
    In effetti do po installato mi ha riconosciuto il dac, solo che adesso mi dà fatal error: credo abbia qualche problema di scrittura sul pendrive.... Sono sufficienti 4gb di spazio?

    Dal profondo della mia ignoranza mi viene comunque da suggerire che dev'esserci qualcosa che non va nello script: forse andrebbe per primo installato alsa e poi il resto...
    Non se la prenda l'autore, sono grossolane interpretazioni di uno che non ne capisce.
    Però mi pare che sia la seconda volta che entra in ballo sto alsa come problema ...
    Ora provo a reinstallare Debian su un'altra pendrive. Poi vi dirò

    Edit: non avevo letto il messaggio sopra, si vede ch comincio a ragionare giusto...

  4. #1224
    byte
    Registrato
    Aug 2015
    Età
    53
    Messaggi
    114

    Predefinito

    I
    Originariamente inviato da bhoga
    Ecco qua il porello utente medio. ...
    Posso continuare qui a chiedere info o preferite che posti in privato?
    Visto che Daphile è al sicuro ed è tutto settato a puntino, mi sto cimentando con l'installazione di Debian32+squeezelite su pendrive.
    Ho già un problema subito: non riconosce il dispositivo di uscita audio connesso (con la versione a 64 bit il Dac era stato riconosciuto subito).
    La risposta che dà è la seguente:

    Elenco dei dispositivi di uscita audio riconosciuti dal sistema:
    ./easetup.sh: riga 75: aplay: comando non trovato

    Suggerimenti?
    Dava lo stesso errore anche a me, ho proseguito con l'installazione ed alla fine la scheda audio l'ha riconosciuta lo stesso.

  5. #1225
    byte
    Registrato
    Aug 2015
    Età
    53
    Messaggi
    114

    Predefinito

    Non
    Originariamente inviato da marcoc1712
    Paolo e cosa dovrei dire io?

    Propongo ci si fermi TUTTI un attimo a riflettere e si risponda a queste semplici domande:

    1. L'obiettivo è sempre:

    a. "fare resampling sul server in modo più semplice rispetto all'utlizzo di custom-convert.conf"

    o è diventato

    b. "installare LMS e squeezelite su Debian in modo automatico e con qualche ottimizzazine"?

    2. Al prossimo che ci chiederà una mano, per usare C-3PO e Squeezelite-R2 cosa suggeriamo?

    a. di installare subito a nuovo con lo script.
    b. facciamo decidere a lui presntandogli PRIMA le diverse modalità.
    c. lo guidamo nella modalità più sicura.

    3. Se b o c, qualsiasi modalità sceglierà di seguire:

    a. lo abbandoniamo se chiede di tornare indietro.
    b. lo accampagnamo a casa chiedendo scusa, siamo pur sempre dichiaratamente in test.

    Chiedo personalmente a Paolo, Giovanni, Filippo e Giorgio di rispondere, in quanto più coinvolti, è ben accetta e stimolata l'opinione di tutti, MAGARI intervenisse anche qualcuno attualmente alla finestra.

    Ce ne fosse bisogno, queste sono le mie risposte:

    1 a,
    2 b o c se è indeciso o poco consapevole.
    3 b.

    Attendo le vs. opinioni (e sposterei questo tipo di discorsi nella bottega, stesse a me).
    Intanto vorrei fare una piccola premessa, ne ho parlato con Giovanni qualche tempo fa a proposito delle sue guide, facendogli notare come una migliore ottimizzazione di quanto già scritto, in modo egregio, avrebbe portato un maggior numero di utenti a seguire il nuovo percorso già segnato. Perchè alla fine, cari ragazzi, il problema è sempre quello, puoi progettare e realizzare il miglior software per la riproduzione audio del mondo ma se non lo rendi fruibile alla più vasta platea possibile di utenti, hai semplicemente fallito.
    Detto questo credo che il core dei nostri discorsi è stato dal primo momento quello di spostare il resampling dal player al server e grazie all'impegno di Marco credo, senza smentita alcuna, che l'obbiettivo è stato centrato in pieno.
    Poi si aggiunto lo script di Paolo, che avrebbe dovuto semplificare l'installazione su un sistema Debian dei vari moduli (LMS, C-3PO e Squeezelite-R2); idea brillante che avrebbe reso possibile l'apertura del nuovo sistema a quanti più utenti possibili solo con l'uso di tre comandi. Purtroppo, in certe installazioni e con un certo hardware, lo script, specialmente con l'ultima versione easetup.sh va in palla e non si raggiunge l'obbiettivo. Nel mio caso specifico ho provato su tre pc diversi, base Debian 64, ad installare con easetup Squeezelite-R2 ma non sono riuscito ad arrivare in fondo. Al contrario non ho avuto alcuna difficoltà ad installare, sempre sugli stessi tre pc, base Debian 32, utilizzando easetup.sh
    Sicuramente bisogna indagare sulle possibili cause che hanno determinato questo fallimento.

    Detto ciò, rispondo al sondaggio di Marco:

    1) a
    2) b o c se è non è convinto o poco consapevole a cosa si va incontro
    3) b

    Fermo restando che lo script di Paolo, appena perfettamente a punto sulle diverse installazioni Debian, DEVE essere necessariamente utilizzato per semplificare la vita al neofita.

  6. #1226
    tebibyte L'avatar di UnixMan
    Registrato
    Sep 2013
    Messaggi
    2,511
    configurazione

    Predefinito

    Originariamente inviato da marcoc1712
    Propongo ci si fermi TUTTI un attimo a riflettere e si risponda a queste semplici domande:

    1. L'obiettivo è sempre:

    a. "fare resampling sul server in modo più semplice rispetto all'utlizzo di custom-convert.conf"

    o è diventato

    b. "installare LMS e squeezelite su Debian in modo automatico e con qualche ottimizzazine"?
    ho come l'impressione che tu abbia frainteso... notevolmente. L'obbiettivo che mi ero posto nel prendermi la briga di realizzare lo script non era certo quello di realizzare il punto "b." fine a se stesso ma, al contrario, proprio quello di fornire una strada, per quanto possibile semplificata e con la minima probabilità di errori, per arrivare al punto "a." (nonché realizzare qualcosa che si avvicinasse al tuo punto "2c."). Seguendo al contempo le raccomandazioni di Giovanni (ed altri) per quanto riguarda il sistema di base e le "ottimizzazioni" varie per ottenere il miglior risultato "sonoro" possibile.

    Non per caso ti avevo anche chiesto se fosse possibile installare C-3PO direttamente dallo script, e magari anche "pre-configurare" sia lui che LMS, di modo che l'utente si trovi con una base di partenza per quanto possibile già "sgrossata" e pronta all'uso (o quasi, secondo quanto si può fare).

    Originariamente inviato da marcoc1712
    2. Al prossimo che ci chiederà una mano, per usare C-3PO e Squeezelite-R2 cosa suggeriamo?

    a. di installare subito a nuovo con lo script.
    b. facciamo decidere a lui presntandogli PRIMA le diverse modalità.
    c. lo guidamo nella modalità più sicura.
    dal mio punto di vista, senza alcun dubbio "b.".

    Quale sarebbe la "modalità più sicura"? Al momento, non mi pare di vederne alcuna. Non per caso: dubito che potrà mai essercene una. Qualsiasi soluzione può presentare una infinità di problemi imprevisti, di vario genere. Incompatibilità con l'hardware, configurazioni inappropriate (rispetto al caso specifico: magari in un altro funzionano benissimo), errori casuali dell'utente nel seguire le istruzioni, ...

    IMHO, la sicurezza del "risultato garantito" non ce la potrai mai avere, se non con una replica esatta -in tutto e per tutto- di un sistema che hai già provato... e che installi e configuri tu stesso, personalmente. Ma perfino in un caso del genere potresti incorrere in problemi imprevisti.

    Dal mio punto di vista, l'unica cosa che si può fare per "massimizzare" (nei limiti del possibile) la probabilità di successo è proprio quella di mettere a punto lo script (ed i pacchetti di R2 che questo installa), facendo il maggior numero possibile di test sul maggior numero possibile di sistemi diversi, e lavorando per analizzare, identificare e risolvere i vari problemi che via via, inevitabilmente, incontreremmo nel corso di una tale impresa. In questo modo quanto meno hai una base di partenza un pelo più uniforme e standardizzata, almeno per quanto riguarda il software e l'organizzazione generale del sistema.

    Possibilità alternativa, per certi versi forse anche migliore (ancora più facile, con ancora meno probabilità di errori ed imprevisti) è quella di saltare completamente l'installazione "in situ" e fornire direttamente delle immagini già pronte all'uso. In tal senso, Giovanni potrebbe voler dare una occhiata a debirf ? CMRG

    Per i nostri scopi, l'idea di un mini sistema Debian che gira completamente in RAM dovrebbe far drizzare diverse antennine...

    Originariamente inviato da marcoc1712
    3. Se b o c, qualsiasi modalità sceglierà di seguire:

    a. lo abbandoniamo se chiede di tornare indietro.
    b. lo accampagnamo a casa chiedendo scusa, siamo pur sempre dichiaratamente in test.
    questa non l'ho mica capita... puoi mica costringere qualcun altro a fare quello che vuoi tu? Se vuole mollare vuole mollare... tanto peggio per lui.
    antonellocaroli likes this.
    Ciao, Paolo.

    «Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee.»

  7. #1227
    tebibyte
    Registrato
    Aug 2011
    Età
    47
    Messaggi
    2,917
    configurazione

    Predefinito

    Originariamente inviato da claudio67

    Fermo restando che lo script di Paolo, appena perfettamente a punto sulle diverse installazioni Debian, DEVE essere necessariamente utilizzato per semplificare la vita al neofita.
    si ma se non si fa Debugging come fa a perfezionarlo?

    e poi sono daccordo con te sul fatto che un obiettivo é stato centrato!!! con l´impegno di Marco...

    sulla domanda qual´é la soluzione piú facile, sopratutto per chi viene da daphile...é tenersi daphile,non sono sarcastico, come player (ma si fanno mille passi indietro) e un server anche con una mint persistente (mi sembra che giovanni ha fatto una guida)

    e per C-3PO mi sembra che marco ha fatto una guida dettagliata....qualcuno l ha letta?

    beh per chi cerca altro...la difficoltá é dietro l´angolo, é questo sarebbe il secondo obiettivo...da dove mi sembra che siamo un po lontani
    dove Paolo ci ha messo anche lui il suo impegno..con mille righe di script...

    ma al di la di questo...nel momento in cui esci dallo schema (daphile) e ti installi una versione di linux devi mettere in conto che un po ci devi sbattere le corna....
    Ultima modifica di antonellocaroli : 15-12-2015 a 20:37
    UnixMan likes this.

  8. #1228
    tebibyte L'avatar di UnixMan
    Registrato
    Sep 2013
    Messaggi
    2,511
    configurazione

    Predefinito

    Originariamente inviato da bhoga
    Ecco qua il porello utente medio. ...
    Posso continuare qui a chiedere info o preferite che posti in privato?
    per i problemi relativi all'uso di easetup, sarebbe meglio se ci spostiamo nel topic dedicato.

    Originariamente inviato da bhoga
    Elenco dei dispositivi di uscita audio riconosciuti dal sistema:
    ./easetup.sh: riga 75: aplay: comando non trovato

    Suggerimenti?
    per qualche motivo (non funzionava la connessione di rete?) l'installazione di alsa-utils - e quindi presumibilmente anche di tutto il resto - è fallita. P.f. guarda i log (sotto /var/tmp/easetup-*/) e mandami quelli dove ti sembra di notare qualche errore (in pvt via e-mail o nell'altro topic).
    marcoc1712 likes this.
    Ciao, Paolo.

    «Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee.»

  9. #1229
    tebibyte
    Registrato
    Aug 2011
    Età
    47
    Messaggi
    2,917
    configurazione

    Predefinito

    Originariamente inviato da UnixMan
    per i problemi relativi all'uso di easetup, sarebbe meglio se ci spostiamo nel topic dedicato.


    per qualche motivo (non funzionava la connessione di rete?) l'installazione di alsa-utils - e quindi presumibilmente anche di tutto il resto - è fallita. P.f. guarda i log (sotto /var/tmp/easetup-*/) e mandami quelli dove ti sembra di notare qualche errore (in pvt via e-mail o nell'altro topic).
    no Paolo non é un problema con la rete...ti mando io i log...tanto ho una live e riprovo...avevo lo stesso errore....

  10. #1230
    tebibyte L'avatar di UnixMan
    Registrato
    Sep 2013
    Messaggi
    2,511
    configurazione

    Predefinito

    Originariamente inviato da bhoga
    Non se la prenda l'autore, sono grossolane interpretazioni di uno che non ne capisce.
    no, ma figurati. Che ci siano ancora un mucchio di problemi da sistemare è più che probabile, direi praticamente certo. A quanto pare in particolar modo in quest'ultima versione. In teoria ci avevo aggiunto solo delle modifiche secondarie, ma nel farlo devo aver introdotto qualche "piccolo" errore che ha mandato a donnine allegre tutto quanto...
    Ultima modifica di UnixMan : 15-12-2015 a 22:53
    Ciao, Paolo.

    «Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee.»

Informazioni Thread

Users Browsing this Thread

Ci sono attualmente 1 utenti che stanno visualizzando questa discussione. (0 utenti e 1 ospiti)

Regole d'invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
nexthardware.com - © 2002-2018

Search Engine Optimization by vBSEO 3.6.1