AudioLinux - un nuovo Sistema Operativo per HQPlayer, ma non solo

Pagina 32 di 38
prima
... 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 ultimo
Visualizzazione dei risultati da 311 a 320 su 379
  1. #311
    kibibyte
    Registrato
    Apr 2014
    Messaggi
    265

    Predefinito

    Uso
    make CFLAGS='-Wall -fPIC -O2 -DLINUX -DALSA -DDSD -DFFMPEG -DRESAMPLE -DVISEXPORT'
    e la sorgente è
    git+https://github.com/marcoc1712/squeezelite-R2

    Quindi immagino che vada bene.

  2. #312
    mebibyte
    Registrato
    Aug 2012
    Località
    Milano - Varese
    Messaggi
    606
    configurazione

    Predefinito

    Originariamente inviato da hifi25nl
    ... Saluti
    Grazie della rapida risposta e della possibilità di fruire ancora del download ... ... Alcuni rapidi commenti:

    [GENERALI]

    - Avevo provato Audiolinux circa 1 anno fa con un laptop ASUS BU201LA equipaggiato I7-4650U con 8GB DRAM ed SSD ma lo avevo accantonato quasi subito, la risposta della macchina era molto "scattosa" pur avendo una occupazione del processore modesta. Riscontravo inoltre molti drop durante la riproduzione anche senza particolari impostazioni di upsampling di HQPlayer (unico player per il quale ho la licenza).

    - Ieri ho recuperato una chiavetta USB3 Sony e gli ho buttato su l'ultima immagine Audiolinux ed ho fatto il boot dalla macchina residente, Dell M6700 I7-3740QM quad core, 12GB DRAM, scheda video NVIDIA Quadro K3000M, SSD che normalmente esegue una Ubuntu 16.04LTS. Al boot mi dá un messaggio <Invalid Partition Table> ma poi parte lo stesso, avevo spianato la chiavetta con <if=/dev/zero> da Ubuntu ma mi sa che è stata formattata da Winzoz e vedrà un MBR sbagliato

    - La prima reazione sull'interfaccia Audiolinux è ora decisamente molto positiva, nulla a che vedere con prima. L'occupazione dei core rimane intorno al 3-4% e la GUI anche se ogni tanto ha qualche tentennamento, si usa senza problemi.Domanda: si puo' impostare lo spegnimento automatico dello schermo dopo 30 secondi di inutilizzo?

    - I dischi presenti nella macchina residente sono elencati tra le cartelle e quindi riconosciuti. Audiolinux, accede senza alcun problema alla scheda SD e ne fruisce i contenuti senza chiedere nulla, per il disco SSD invece mi viene richiesta la root password, siccome però l'utente owner del disco si chiama <u1> non riesco a capire come fare a consentire la lettura senza cambiare l'ownership dello stesso tutte le volte che passo da Audiolinux a Ubuntu (forse devo creare anche un utente <root> sull'Ubuntu in modo che poi quando Audiolinux si presenta come root, viene autenticato)

    - Il DAC JLSounds con la scheda I2SoverUSB viene riconosciuto immediatamente. Entrambi PCM e DSD non-DoP funzionano.

    - In PCM non ho fatto molte prove perchè di solito funziona senza intoppi

    - In DSD, il cambio risoluzione è gestito correttamente. Ho avuto solo 1 volta dei "rumoracci" al Play, tipo DSD non decodificato. Anche in questo caso il DAC saltuariamente richiede di essere "reimpostato" in modalità DSD Volume ByPass per uscire dal mute alla prima traccia ma è un problema del dac stesso, credo, perchè mi capita con vari players.

    [SUONO]

    - Il mio player resident da parecchio tempo è WTF uwtfdsd (0.5 o 0.6) versione I7 no-AVX che ha una focalizzazione stellare degli esecutori sulla scena ma la "palla" sovrumana della pausa tra una traccia e l'altra (che sul mio DAC con i relè del mute significa 2 secondi di buco)

    - Audiolinux nell'ascolto di una sera, si è rivelato ora molto interessante.

    Ancora non riesco a capire come sia possibile che il DAC JLSounds con 3 alimentazioni separate e scheda di reclock con i Crystek, possa evidenziare differenze di suono cambiando il player software ma cosí accade ed in mancanza di strumentazione adeguata a dimostrare se sono rincoglionito o meno, mi adeguo senza troppe fisime. Purtroppo l'impianto è ancora messo in un angolo della stanza e si esprime al 50% (per essere buoni) ma ormai ci ho fatto l'orecchio.

    Ritornando al suono, rispetto a WTF, Audiolinux mi ha tirato fuori un suono che riempie maggiormente le tre dimensioni dello stage, come sempre descrivere la musica con la tastiera è un casino ... Per fare un esempio. Cantante e quattro strumentisti acustici sul palco, WTF posiziona i 5 in modo chirurgico sul palco con suoni più separati tra loro e la voce che esce netta dal gruppo, come se ascoltassi il live con la voce predominante dall'amplificazione del concerto e gli strumenti prevalentemente diretti. Audiolinux "spalma" maggiormente il suono nel contesto, come se nello stesso concerto ascoltassi solo il suono diretto, voce e strumenti.

    Molto bene ...

    - Ho provato il boot RT con il parametro per Intel che tiene fisso il clock a 2.7GHz ed il suono migliora ulteriormente, l'occupazione CPU è identica ma le ventole girano costantemente per tenere la temperatura normale. Il mio è un Workstation portatile, non è rumorossimo ma si sentono

    A presto. Un cordiale saluto, Massimiliano

  3. #313
    kibibyte
    Registrato
    Apr 2014
    Messaggi
    265

    Predefinito

    Grazie dei commenti, soprattutto sul suono.
    Non sei il primo che dice che funziona meglio facendo il boot con "Extreme". L'opzione però non è adatta ad un portatile poiché il processore non va mai in uno stato di "power saving".
    A mio parere i risultati sono molto legati al valore record della latenza del processore. Sono arrivato, su un i7-4770, a 2 microsecondi con punte di soli 5 microsecondi

    1) Per quanto riguarda la pennetta non era necessaro "spianarla" prima, basta eseguire il comando (da linux)
    gunzip -c /mnt/audiolinux.img.gz | dd of=/dev/sdx
    dove bisogna sostituire sdx con l'indrizzo della pennetta che si può ricavare con
    fdisk -l
    NON bisogna usare, per esempio, sdc1 invece di sdc, altrimenti la copia non sarà corretta. Audiolinux consiste in due partizioni, UEFI e ext4, e bisogna copiare l'intera immagine, operazione che eliminerà qualsiasi partizione fosse stata presente sull'hard disk target.
    Per ottenere lo stesso risultato in windows invece bisogna selezionare l'opzione DD nell'applicazione Rufus.
    Ovviamente bisognerà dare priorità a USB nelle opzioni di boot della BIOS.

    2) Se ho capito bene, l'hard disk SSD dovrebbe essere formattato ext4. In teoria, dando la password root "audiolinux0" di audiolinux (non quella di Ubuntu, che non ha nessuna rilevanza in questo caso) dovrebbe essere montato correttamente, a meno che non sia criptato...
    Eventualmente, apri una finestra di terminale, entra in root con il comando "su" seguito poi dalla password "audiolinux0" e mandami il risultato di
    fdisk -l

    3) Per lo schermo nel Settings manager xfce4 puoi trovare tutte le opzioni di spegnimento/standby.

    Buon ascolto!

  4. #314
    pebibyte L'avatar di marcoc1712
    Registrato
    Jan 2013
    Messaggi
    5,248
    configurazione

    Predefinito

    Originariamente inviato da hifi25nl
    Uso
    make CFLAGS='-Wall -fPIC -O2 -DLINUX -DALSA -DDSD -DFFMPEG -DRESAMPLE -DVISEXPORT'
    e la sorgente è
    git+https://github.com/marcoc1712/squeezelite-R2

    Quindi immagino che vada bene.
    Si, potresti togliere qualche opzione (-DFFMPEG -DRESAMPLE -DVISEXPORT) per un uso minimalista solo con C-3PO, ma non è fondamentale e - forse - a te fa gioco più così (meno problemi di supporto).

    Quando rilascerò la nuova versione ti basterà fare la fetch della nuova versione (o clonarti nuovamente il repository) e ricompilare.
    Ciao, Marco.

    "Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius -- and a lot of courage -- to move in the opposite direction."
    — E. F. Schumacher (mis-attributed to A. Einstein)
    ________________________________________________________________________________
    Autore della patch R2 per Squeezelite e del plugin C-3PO. note libere
    Logitech media Server 7.9 > miniPc + squeezelite-R2 / SB+ > "Lu Scalmentu" NOS R2R DAC by TubeOne/ AudioResearch DAC 1-20 >
    Klimo Merlino Gold TPS > DIS Interconnect > Kent Gold > Reference > Monitor Audio Studio 20 SE

  5. #315
    mebibyte
    Registrato
    Aug 2012
    Località
    Milano - Varese
    Messaggi
    606
    configurazione

    Predefinito

    Originariamente inviato da hifi25nl
    Grazie dei commenti, soprattutto sul suono...
    Ti confermo che con questa macchina Dell M6700, il risultato è notevole.

    - Ho disattivato i controlli di power della CPU da BIOS e mi sembra che vada in generale meglio
    - Anche la latenza mi sembra buona, immensamente diversa da quello che accadeva con l'Asus BU201LA che comunque non era proprio una "chiavica". In questo caso quando lancio il CyclictestoScope ho un picco che mi fa cambiare la scala ma durante la riproduzione di un file DSD64 in loop, direi a naso che sto Average 5-6uSec e 17uSec Max (anche con un DSD128 uguale):

    - Con una traccia test DSD256 il comportamento è un pò diverso, la latenza mi sta quasi sempre bassa a 10-20uSec ma ogni tanto c'e' dentro un picco o 3-4 picchi di seguito intorno a 500uSec, temperatura mediamente a 53-54' ed occupazione della CPU con qualche processore che ciclicamente visualizza 50% e mediamente tra 10-20%. Nessuna interruzione di sorta nel playout. Le due ventole (grosse) della workstation portatile girano a velocità decorosa ed a 1/2 metro non si sentono.

    - L'HD interno SSD lo vedo correttamente, pensavo di dover mettere la pwd dell'Ubuntu residente che gestisce normalmente il disco, invece ho messo la root di Audiolinux e tutto si è risolto

    - Ok anche per la gestione dello schermo, impostato il blank ad un minuto

    [SUONO]

    Tralascio l'incaxxatura di sentire come suona una traccia Test in DSD256, cioè di capire immediatamente le potenzialità del digitale quando non castrato dal solito 16/44 ...

    Sto cercando di ascoltare qualche traccia Test DSD impostando HQP con DirectSDM/+6dB/conversion=poly-short-mp/Integrator=FIR/NoiseFilte=standard (magari si puo' fare di meglio) in modo da avere un intervento minimale da parte di HQP e poter bypassare il volume del DAC JLSounds, cosa non possibile in PCM.

    Il rultato come dicevo ieri è un pò spiazzante. Con WTF mi ero abituato a "vedere" uno spot di luce che illuminava gli esecutori sul palco, dei bronzi di Riace con uno sfondo scuro; con questa combinazione Audiolinux/HQP è come avere una luce alogena che illumina tutto in modo diffuso, interessante. Molto naturale ed intima come riproduzione devo dire, in particolare per le cose tipo voce/chitarre acustiche in ambiente piccolo ... Nei live, ci si sposta indietro rispetto al palco di un po' di metri rispetto a WTF ... misteri del computer audio!

    Devo capire se posso/devo fare altro per ottimizzare il sistema ...

    Un cordiale saluto, Massimiliano
    Ultima modifica di Ipoci : 01-03-2017 a 23:52
    bibo01 likes this.

  6. #316
    mebibyte
    Registrato
    Aug 2012
    Località
    Milano - Varese
    Messaggi
    606
    configurazione

    Predefinito

    Vabbè ... nel frattempo che rimetto mano al DAC che si è guastato ...

    - Posso upgradare Audiolinux con l'ultimo HQPlayer 3.16?

    - Con HQPlayer in Audioinux, posso abilitare in qualche modo l'accellerazione CUDA GPU NVIDIA? In Ubuntu 16.04LTS ho installato il blocco di drivers ver.367.57 (altri non funzionano), e durante il playout HQP tramite il comando <nvidia-smi> vedo che la scheda è correttamente gestita.

    Un cordiale saluto, Massimiliano

  7. #317
    kibibyte
    Registrato
    Apr 2014
    Messaggi
    265

    Predefinito

    Per fare l'upgrade basta reinstallarlo. In un terminale:
    yaourt -S hqplayer

    Questa mattina ho aggiornato hqplayer alla versone 3.16

    Per quanto riguarda CUDA bisogna installare i driver proprietari Nvidia. Audiolinux di default usa il driver nouveau di X. Ricordo anche che bisogna avere una scheda NVIDIA high-end, altrimenti il risultato potrebbe essere peggiore.

    Grosso modo la procedura è questa:

    1) Rimuovere nvidia, nvidia-rt e tutti relativi pacchetti, se presenti (se per caso era stata tentata l'installazione di qualche driver proprietario)
    yaourt -R nvidia nvidia-libgl nvidia-rt

    2) Rimuovere il driver "nvidia" linux non proprietario
    yaourt -R xf86-video-nouveau

    3) Rimuovere qualsiasi file di configurazione in
    /etc/X11/xorg.conf.d/

    4) Installare nvidia-dkms
    yaourt -S nvidia-dkms nvidia-settings nvidia-utils opencl-nvidia

    5) Aggiungere il file 20-nvidia.conf in allegato in /etc/X11/xorg.conf.d/

    6) Verificare che il driver nvidia non sia in blacklist in /etc/modprobe.d/

    7) Fare il reboot e verificare che tutto funzioni. A questo punto installare CUDA con
    yaourt -S cuda

    Contenuto del file 20-nvidia.conf

    Section "Device"
    Identifier "Nvidia Card"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option "NoLogo" "true"
    Option "Coolbits" "4"
    EndSection
    Ultima modifica di hifi25nl : 16-03-2017 a 11:21

  8. #318
    kibibyte
    Registrato
    Apr 2014
    Messaggi
    265

    Predefinito

    Prossimamente (probabilmente entro un paio di settimane) inizierò a pubblicare una serie di recensioni-test di audiolinux.

    Comincerò con
    1) Holo Audio Spring, un dac R2R rivoluzionario con correzione linearità e una sezione DSD che usa anch'essa una combinazione di resistenze.
    2) PinkFaun Streamer + DAC, con una versione di Audiolinux concepita appositamente per lo Streamer.

  9. #319
    kibibyte
    Registrato
    Apr 2014
    Messaggi
    265

    Predefinito

    Per l'Holo Audio, che è arrivato, aspetto che passino un po' di ore... il suono è sorprendente, non pensavo che un DAC potesse suonare così diverso! Comunque la novità interessante è che in DSD non c'è nessun bump passando da una traccia ad un'altra, anche cambiando frequenza!

    Per ottenere il DSD nativo bisogna applicare una patch al kernel linux. Ovviamente l'ho già fatto... l'ultimo kernel lo potete trovare qui:
    Index of /ftp/packages/kernel/last
    UnixMan likes this.

  10. #320
    mebibyte
    Registrato
    Aug 2012
    Località
    Milano - Varese
    Messaggi
    606
    configurazione

    Predefinito

    Il mio nuovo portatile HP ZBook G2 17" con dentro un i7-4940XM ho visto che mantiene la latenza sotto i 10mSec, stranamente la CPU% e' piu' alta di quello che era l'occupazione del Dell i7-3740QM ...Misteri della mistica informatica. Stasera provo ad aggiornare Audiolinux con la nuova versione di HQP ed a installare i drivers NVIDIA CUDA che questa macchina qui ha dentro una scheda K5100M che dovrebbe andare meglio della precedente K3000M.

    Il DAC pero' è ancora guasto.

    Un cordiale saluto, Massimiliano

Informazioni Thread

Users Browsing this Thread

Ci sono attualmente 1 utenti che stanno visualizzando questa discussione. (0 utenti e 1 ospiti)

Regole d'invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
nexthardware.com - © 2002-2018

Search Engine Optimization by vBSEO 3.6.1