Like Tree111Likes

Consigli per un server

Pagina 11 di 21
prima
... 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 ... ultimo
Visualizzazione dei risultati da 101 a 110 su 206
  1. #101
    tebibyte L'avatar di UnixMan
    Registrato
    Sep 2013
    Messaggi
    2,509
    configurazione

    Predefinito

    Originariamente inviato da squonk
    Ok, disinstallato XFCE, adesso funziona!
    Alcune cose non mi funzionano più: se dal menu grafico di MATE seleziono Gestione pacchetti (che dovrebbe lanciare synaptic) non succede nulla, sono costretto a lanciarlo da riga di commando. Non capisco perchè...
    ma da riga di comando parte? In tal caso, potrebbe essere un problema con i menù. Forse disinstallando XFCE hai disinstallato anche alcune librerie o componenti accessori utilizzati anche da MATE. Prova ad es. a vedere se il pacchetto "menu" è installato (ad es., "dpkg -l |grep -i menu").
    squonk likes this.
    Ciao, Paolo.

    «Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee.»

  2. #102
    kibibyte
    Registrato
    May 2012
    Messaggi
    308

    Predefinito

    Originariamente inviato da UnixMan
    ma da riga di comando parte? In tal caso, potrebbe essere un problema con i menù. Forse disinstallando XFCE hai disinstallato anche alcune librerie o componenti accessori utilizzati anche da MATE. Prova ad es. a vedere se il pacchetto "menu" è installato (ad es., "dpkg -l |grep -i menu").
    Il comando che mi hai scritto restituisce una marea di risultati, tra cui anche una voce chiamata semplicemente "menu".
    Io ritengo che non sia un problema della rimozione di XFCE perchè il problema ce lo avevo anche prima: mi scuso perchè in effetti nel mio post precedente ho scritto che la cosa si è verificata dopo la rimozione.
    Comunque: sì, da linea di comando synaptic parte senza problemi, dal menu grafico no. Le altre voci del menu sembrano funzionare normalmente...
    Non è che è un problema di permessi?

  3. #103
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    40
    Messaggi
    23,016
    configurazione

    Predefinito

    Forse manca il pacchetto gksudo?
    squonk and UnixMan like this.

    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Ognuno capì che Nessuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

  4. #104
    kibibyte
    Registrato
    May 2012
    Messaggi
    308

    Predefinito

    Originariamente inviato da frakka
    Forse manca il pacchetto gksudo?
    Sicuro che MATE lo usi? Io non lo trovo con synaptic...
    EDIT
    Mi rispondo da solo. In realtà è usato gksu che è normalmente installato...
    Ultima modifica di squonk : 16-03-2016 a 23:25

  5. #105
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    40
    Messaggi
    23,016
    configurazione

    Predefinito

    No, era un input per UnixMan... Potrebbe anche non chiamarsi così.
    Non uso ubuntu da anni quindi non la conosco molto bene.
    UnixMan and squonk like this.

    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Ognuno capì che Nessuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

  6. #106
    kibibyte
    Registrato
    May 2012
    Messaggi
    308

    Predefinito

    Sembra che non sia il solo ad avere questo problema.
    Ho trovato una discussione sul forum di Ubuntu in merito.
    Andando nella voce di menu e modificando il comando da synaptic-pkexec a gksudo synaptic la voce di menu ha ricominciato a funzionare.
    La discussione è questa (nel forum relativo a Lubuntu). Verso la fine si parla di una soluzione che permette di far funzionare il comando originale (synaptic-pkexec), ma non ho capito bene...
    Altro mistero.
    Comunque devo essere particolarmente sfigato perchè qualunque cosa faccia ne becco sempre una. Ma sono l'unico o con linux è normale?

  7. #107
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    40
    Messaggi
    23,016
    configurazione

    Predefinito

    Penso che succeda a tutti quelli che si cimentano in qualcosa che non sanno fare o che non conoscono: Si chiama "imparare ".
    UnixMan likes this.

    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Ognuno capì che Nessuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

  8. #108
    tebibyte L'avatar di UnixMan
    Registrato
    Sep 2013
    Messaggi
    2,509
    configurazione

    Predefinito

    Originariamente inviato da squonk
    Ho trovato una discussione sul forum di Ubuntu in merito.
    bravo.

    Originariamente inviato da squonk
    Andando nella voce di menu e modificando il comando da synaptic-pkexec a gksudo synaptic la voce di menu ha ricominciato a funzionare.
    bene.

    Mi sono dimenticato un consiglio importante: nei sistemi Unix/Linux tutte le configurazioni relative a ciascun utente vengono registrate in files e/o directories "nascoste" (cioè il cui nome comincia con un '.') nella "home directory" dell'utente stesso (che di solito corrisponde a /home/nomeutente). Quando (come nel tuo caso) si apportano cambiamenti sostanziali al sistema (passaggio a DE diversi, aggiornamenti di versione maggiori, ecc), è spesso opportuno eliminare (archiviare/spostare altrove) tutte le vecchie configurazioni in modo da ripartire da zero. Si evitano così un mucchio di possibili problemi subdoli. Il modo più semplice e veloce per farlo è probabilmente quello di spostare tutto in un'altra directory:
    codice:
    mkdir  ~/old  &&  mv -iv  .[^.]*  ~/old/
    ...e poi spostare (o copiare) indietro le poche cose che si devono mantenere, ad es. di sicuro i "files di configurazione" (startup script) della shell:
    codice:
    mv -iv  ~/old/.bash*  ~/old/.*profile*  ~/
    N.B.:

    1) questa operazione va eseguita necessariamente in modo testo (da console o da una shell remota), avendo cura che non vi sia nessuna applicazione (né tanto meno sessione del desktop) aperta da parte di quell'utente;

    2) il carattere "~" è un comodo "shortcut" che viene automaticamente sostituito dalla shell con il path completo della home dir dell'utente che esegue il comando;

    3) la notazione '&&' indica un "AND" logico. In sostanza in questo caso serve ad eseguire il comando a destra solo se il primo (quello a sinistra) è stato eseguito senza errori (ovviamente puoi anche evitarla e dare invece i due comandi in sequenza, separatamente).

    4) la sintassi '.[^.]*' significa qualsiasi nome che comincia con '.', seguito da (almeno) un altro carattere che non sia un altro '.' ed eventualmente da un numero qualsiasi di altri caratteri (qualsiasi). In altre parole "matcha" qualsiasi files o directory il cui nome comincia per '.', ad eccezione di '.' (directory corrente) e '..' (parent directory).

    In effetti lascia fuori anche qualsiasi file/dir il cui nome cominci per '..' (seguito da altri caratteri); di solito non dovrebbero essercene ma, ad ogni buon conto, volendo puoi aggiungere anche '..?*' (che significa qualsiasi nome che comincia con '..' seguito da almeno un altro carattere qualsiasi) per prenderti cura anche di quelli. Puoi farlo anche in un colpo solo con il comando "mv -iv .[^.]* ..?* ~/old/" (probabile che otterrai un messaggio di errore del tipo: "cannot access ..?*: No such file or directory"... ma non è un problema).

    Originariamente inviato da squonk
    La discussione è questa (nel forum relativo a Lubuntu). Verso la fine si parla di una soluzione che permette di far funzionare il comando originale (synaptic-pkexec), ma non ho capito bene...
    verifica che sia installato il pacchetto: "policykit-1" (leggi qui per capire di cosa si tratta).

    Originariamente inviato da squonk
    Comunque devo essere particolarmente sfigato perchè qualunque cosa faccia ne becco sempre una. Ma sono l'unico o con linux è normale?
    come ha giustamente detto frakka, è del tutto normale. Negli anni ho avuto modo di notare che di fronte ad un sistema Linux si trova e si adatta prima e meglio chi ha poca o nessuna abilità/esperienza informatica pregressa rispetto a chi invece è già più esperto/smaliziato nell'uso di un qualche altro sistema diverso. Inizialmente la cosa mi sorprese, poi mi sono reso conto che è ovvio... è più facile imparare a fare qualcosa partendo da zero piuttosto che dover cambiare abitudini e paradigmi già acquisiti. Anche la percezione della difficoltà cambia. Quando sai fare qualcosa quella per te diventa facile; nel momento in cui ti trovi a dover fare una cosa simile in modo diverso ma non sai come e non ci riesci la cosa è particolarmente frustrante... e la percezione soggettiva è quella di una difficoltà esagerata. Ma si tratta di una mera (e naturale) questione psicologica... doversi "rimettere in gioco" e ripartire da zero è sempre difficile, per chiunque ed in qualsiasi contesto.
    Ultima modifica di UnixMan : 17-03-2016 a 14:30
    squonk and bigtube like this.
    Ciao, Paolo.

    «Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee.»

  9. #109
    kibibyte
    Registrato
    May 2012
    Messaggi
    308

    Predefinito

    Domanda.
    Ho una cartella di Logitech Media Server in /var/lib/squeezeboxserver che ho bisogno di condividere per potervi accedere da remoto.
    Con Samba ho condiviso una cartella nella quale ho montato i dischi fissi con i dati e riesco ad accedervi anche da Windows senza problemi.
    Vorrei mettere un link alla cartella di cui sopra e l'ho fatto con il comando
    codice:
    ln -s <file-o-directory-di-destinazione> <posizione e nome del link>
    Da linux tutto funziona come aspettato, ma quando mi trovo in Windows e accedo alla cartella condivisa (è connessa come unità di rete) la cartella si vede, ma non riesco ad accedervi per problemi di permessi.
    Ho provato a dare i seguenti comandi:
    codice:
    sudo chown -R utente:utente <nome cartella con link>
    sudo chown -R utente:utente </var/lib/squeezeboxserve>
    ma non è cambiato nulla (va da sè che da Windows per accedere alla cartella condivisa utilizzo le credenziali di "utente").
    Come posso fare?

    AGGIORNAMENTO
    Mmmmmm, il problema è meno semplice del previsto.
    Modificare il diritti sulla cartella di LMS rende il programma non funzionante (aggiornandolo tutto è tornato a posto).
    Ho cambiato strategia, cioè ho lasciato perdere i link ed ho provato a condividere direttamente la cartella col database di LMS. Adesso da Windows riesco ad accedervi senza problemi, ma in sola lettura (nonostante in Samba abbia configurato l'accesso anche in scrittura).
    Basta, per oggi ci rinuncio e vado a letto!
    Ultima modifica di squonk : 18-03-2016 a 01:00

  10. #110
    pebibyte L'avatar di marcoc1712
    Registrato
    Jan 2013
    Messaggi
    5,240
    configurazione

    Predefinito

    Originariamente inviato da squonk
    Domanda.
    Ho una cartella di Logitech Media Server in /var/lib/squeezeboxserver che ho bisogno di condividere per potervi accedere da remoto.
    Con Samba ho condiviso una cartella nella quale ho montato i dischi fissi con i dati e riesco ad accedervi anche da Windows senza problemi.
    Vorrei mettere un link alla cartella di cui sopra e l'ho fatto con il comando
    codice:
    ln -s <file-o-directory-di-destinazione> <posizione e nome del link>
    Da linux tutto funziona come aspettato, ma quando mi trovo in Windows e accedo alla cartella condivisa (è connessa come unità di rete) la cartella si vede, ma non riesco ad accedervi per problemi di permessi.
    Ho provato a dare i seguenti comandi:
    codice:
    sudo chown -R utente:utente <nome cartella con link>
    sudo chown -R utente:utente </var/lib/squeezeboxserve>
    ma non è cambiato nulla (va da sè che da Windows per accedere alla cartella condivisa utilizzo le credenziali di "utente").
    Come posso fare?

    AGGIORNAMENTO
    Mmmmmm, il problema è meno semplice del previsto.
    Modificare il diritti sulla cartella di LMS rende il programma non funzionante (aggiornandolo tutto è tornato a posto).
    Ho cambiato strategia, cioè ho lasciato perdere i link ed ho provato a condividere direttamente la cartella col database di LMS. Adesso da Windows riesco ad accedervi senza problemi, ma in sola lettura (nonostante in Samba abbia configurato l'accesso anche in scrittura).
    Basta, per oggi ci rinuncio e vado a letto!
    Forse ho capito male, ma se stai provando ad accedere al file del db (library.db) su linux usando sqlmanager dal browser sulla macchina windows mediante la condivisione samba, è probabile che ti consenta l'accesso in sola lettura xchè è già attivo LMS con accesso esclusivo. Puoi provare a chiudere LMS e vedere se accedi in lettura e scrittura. SQLIte non è pensato per la multiutenza, era molto meglio con mysql, ma hanno cambiato. In ogni caso, non è molto consigliabile modificare manualmente il DB di LMS, ma soprattutto sarebbe molto meglio accedervi tramite connessione ODBC che non aprendo un file su un altro OS.
    UnixMan and squonk like this.
    Ciao, Marco.

    "Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius -- and a lot of courage -- to move in the opposite direction."
    — E. F. Schumacher (mis-attributed to A. Einstein)
    ________________________________________________________________________________
    Autore della patch R2 per Squeezelite e del plugin C-3PO. note libere
    Logitech media Server 7.9 > miniPc + squeezelite-R2 / SB+ > "Lu Scalmentu" NOS R2R DAC by TubeOne/ AudioResearch DAC 1-20 >
    Klimo Merlino Gold TPS > DIS Interconnect > Kent Gold > Reference > Monitor Audio Studio 20 SE

Pagina 11 di 21
prima
... 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 ... ultimo

Informazioni Thread

Users Browsing this Thread

Ci sono attualmente 1 utenti che stanno visualizzando questa discussione. (0 utenti e 1 ospiti)

Regole d'invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
nexthardware.com - © 2002-2018

Search Engine Optimization by vBSEO 3.6.1