Fedora 23 pare aver disabilitata la lista di "files recenti" (e apps), o meglio, il campo c'e' ma e' perennemente vuoto a prescindere che si usino o meno documenti.
Dal forum di kde per fixare:

Add something like that to ~/.kde/share/config/kdeglobals: (or change it accordingly if that group already exists)

You have to change the value of MaxEntries to your preference of course.
With UseRecent=false you could disable it completely, UseRecent=true can be omitted since it's the default.

Or just use kwriteconfig to change it:
kwriteconfig --group RecentDocuments --key MaxEntries 15
To disable it:
kwriteconfig --group RecentDocuments --key UseRecent false
You may have to logout/login for the change to have effect.