Problema con GRUB2

Pagina 2 di 4
prima
1 2 3 4 ultimo
Visualizzazione dei risultati da 11 a 20 su 39
  1. #11
    bit
    Registrato
    Jan 2014
    Messaggi
    20

    Predefinito

    Mi scuso per l'assenza ma ho avuto da fare in questi giorni. Ho provato a seguire i tuoi consigli. Ho commentato tutta la parte che mi hai indicato e aggiunto al menù di GRUB la voce che mi hai postato. Fatto questo ho riaperto il file grub.cfg per vedere se le modifiche erano andate a buon fine e ho scoperto che Linux mi ha bellamente tolto tutti i commenti che avevo messo. Ho comunque riavviato e dato invio sulla nuova voce che però mi segnala due errori:

    error: no such disk
    error: no such partition

    Come possiamo fare?

  2. #12
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    38
    Messaggi
    22,116
    configurazione

    Predefinito

    Sembra che non identifichi correttamente i drive... Ma non capisco perchè.

    Prova così, giusto ridere:
    codice:
    menuentry "Microsoft Windows7" {
        insmod ntfs
        chainloader +1
    }
    Ma non penso che funzioni... Bisognerebbe capire perchè.


    In alternativa, possiamo creare una voce che funzioni come un fix rapido: Non è proprio elegante ma dovrebbe funzionare, intanto che troviamo una soluzione. Nel bios del portatile imposti il disco di Linux come primo disco di avvio e quello di Windows come secondo. Poi crei una voce di questo tipo, di seguito alle precedenti che ti ho indicato:

    codice:
    menuentry "Chiudi GRUB e avvia il prossimo disco" {
     exit
    }
    Questa voce in realtà non fà altro che uscire da GRUB e passare l'avvio al secondo disco impostato nella sequenza di boot del firmware. E' un trucco poco elegante ma dovrebbe funzionare.


    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Ognuno capì che Nessuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

  3. #13
    bit
    Registrato
    Jan 2014
    Messaggi
    20

    Predefinito

    Allora:

    menuentry "Microsoft Windows7" {
    insmod ntfs
    chainloader +1
    }

    Mi da il solito errore: error: invalid EFI file path

    Mentre

    menuentry "Chiudi GRUB e avvia il prossimo disco" {
    exit
    }

    Non mi ha dato neanche il tempo di esultare che..... Windows si è piantato. Nel senso che parte la schermata di avvio ma poi si blocca

    Probabilmente c'è un legame tra il fatto che quando avvio Windows con exit si blocca e il problema della partizione/disco che non trova GRUB.
    Ultima modifica di Ticio : 01-02-2014 a 18:31

  4. #14
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    38
    Messaggi
    22,116
    configurazione

    Predefinito

    Il primo errore dipende, appunto, dal fatto che Win7 è installato in MBR mentre il bootloader si aspetta diavviare un EFI. Come ti dicevo, non ci contavo molto...

    Devo riguardare una vecchia discussione avuta con l'utente marcosaurus, che riguardava un problema simile. Probabilmente non è possibile fare il chainloading di un sistema operativo di tipo "diverso" (intendo avviare un sistema UEFI/GPT da un bootloader MBr e viceversa), altrimenti non si spiega il perchè non funzioni il trucchetto di "exit".


    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Ognuno capì che Nessuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

  5. #15
    bit
    Registrato
    Jan 2014
    Messaggi
    20

    Predefinito

    Grazie mille ancora per l'aiuto che mi stai dando Attendo tue notizie

  6. #16
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    38
    Messaggi
    22,116
    configurazione

    Predefinito

    Mi sono riletto la vecchia discussione avuta con l'altro utente e purtroppo anche nell'altro caso eravamo giunti alla stessa conclusione: Non si riesce ad avviare un sistema MBR da un bootloader (grub) avviato in modalità UEFI.
    Però nel suo caso, il comando "exit" ha funzionato come atteso quindi non capisco perchè a te non vada.
    http://www.nexthardware.com/forum/gn...tml#post866052

    Inizialmente si era presentato un problema dovuto alla presenza di voci duplicate nel firmware: Sei sicuro che non ci siano problemi riconducibili a questo?


    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Ognuno capì che Nessuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

  7. #17
    bit
    Registrato
    Jan 2014
    Messaggi
    20

    Predefinito

    Come faccio a verificarlo? Con efibootmgr -v? Se sì, allora non ho voci duplicate.
    Ultima modifica di Ticio : 01-02-2014 a 20:50

  8. #18
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    38
    Messaggi
    22,116
    configurazione

    Predefinito

    Questo è il mio:
    codice:
    [root@redhat-host matteo]# efibootmgr
    BootCurrent: 0002
    Timeout: 3 seconds
    BootOrder: 0002,0000
    Boot0000* Windows Boot Manager
    Boot0002* Red Hat Enterprise Linux
    Ripulisci i vari script che hai toccato finora, entra nel bios e accertati che sia selezionato come primo dispositivo di avvio la voce relativa a Linux in modalità UEFI e come seconda voce l'indicazione relativa al disco su cui è installato il bootloader di Windows (dovrebbe essere il disco di Windows).
    Torna il linux e crea la voce di grub equivalente al solo comando "exit". Posta anche un efibootmgr come ho fatto sopra.

    Usi ibernazione/sospensione in Windows??


    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Ognuno capì che Nessuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

  9. #19
    bit
    Registrato
    Jan 2014
    Messaggi
    20

    Predefinito

    Cosa intendi per ripulire i vari script che ho toccato fino a ora?

    efibootmgr mi restituisce questo:

    BootCurrent: 0000
    Timeout: 1 seconds
    BootOrder: 0000,0001,0002
    Boot0000* linuxmint
    Boot0001* Hard Drive
    Boot0002* CD/DVD Drive

    L'ibernazione l'ho disattivata e la sospensione la uso

  10. #20
    Super Moderatore L'avatar di frakka
    Registrato
    May 2001
    Località
    Casalecchio di Reno (Bo)
    Età
    38
    Messaggi
    22,116
    configurazione

    Predefinito

    Togliere le modifiche fatte finora per ripartire da una situzione "pulita".

    Accertati solo che quando provi il funzionamento di Grub Windows non arrivi da uno stato diverso da spento (no sospeso, no ibernato) perchè potrebbe creare dei problemi.
    La voce "Boot0001* Hard Drive" punta al disco corretto?

    Onestamente non saprei, anche in base all'esperienza di marcosaurus dovrebbe funzionare...


    Questa è la storia di 4 persone chiamate Ognuno, Qualcuno, Ciascuno e Nessuno. C'era un lavoro importante da fare e Ognuno era sicuro che Qualcuno lo avrebbe fatto. Ciascuno poteva farlo, ma Nessuno lo fece, Qualcuno si arrabbiò perché era il lavoro di Ognuno. Ognuno pensò che Ciascuno potesse farlo, ma Ognuno capì che Nessuno l'avrebbe fatto. Finì che Ognuno incolpò Qualcuno perché Nessuno fece ciò che Ciascuno avrebbe potuto fare.

Pagina 2 di 4
prima
1 2 3 4 ultimo

Informazioni Thread

Users Browsing this Thread

Ci sono attualmente 1 utenti che stanno visualizzando questa discussione. (0 utenti e 1 ospiti)

Regole d'invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
nexthardware.com - © 2002-2018

Search Engine Optimization by vBSEO 3.6.1